Image assets fail to load

On some seemingly random day, 4 image assets that had been apart of my game for a while began to never load.

This happens all in playtest, the public game, and in studio, and for all players/editors.

It has been about a month and I have tried many things, including: Clearing my http cache, reinstalling studio, reuploading the map image with a slightly different graphic under a new file and name(3 times), and replacing the part they a part of. All images are my unique images.

The “crusted map” just started erroring about a week after I reuploaded it. I think its any new assets since some date I do not know, but I just added a new image today so I will have to see in about a week. We were hoping to publish this week though… oh well. It does appear to be only my assets as of rn, but I do not know if my other editor has added any assets since this began. It is only this game.
This is the image of the map so you know it is not inappropriate (I received no moderation)


Maybe there is too much transparency?
It also fails to load on the website, the link to it never loads:

I do all my images as PNG’s, these ones are 8 bit and/or 16 bit.
So far it has only happened with images.

Windows 10 Home ; Up to date
comsouth ; Linksys smart wifi
Radeon RX 480
AMD FX-6300 Six-Core Processor

We reuploaded a completely white image and got the same error.


Completely transparent images are not only pointless but they will be rejected.

Try posting in #platform-feedback:moderation-review-requests for all the ones that show up as being rejected with that :no_entry_sign: thumbnail to request the moderation action be reversed.

I mean white. Which are not pointless. I literally am not allowed to upload any images successfully, let alone assets.

I have been seeing a similar bug where uploaded images on my gui do not load. The image still shows in game explorer though.

If they have the :no_entry_sign: symbol then they’ve been moderated, so post in #platform-feedback:moderation-review-requests or message the Mod_Review_Requests group.

vietj1 is a member, so cannot access or message mod review requests

1 Like

Ah, didn’t realise you couldn’t message them either. It feels wasteful and messy to do this, but even with access to the reviews it’s often quicker to just re-upload and swap out the assets if you’re confident there’s nothing against the guidelines in there.

We have tried this 6 times with one image, we change the file, file name, image, file location, and asset name each time. Still, instant moderation.

This may sound insane but try changing 1 single pixel in the image and see if that fixes the issue.

That is what we have done many times. This is why they are all named something related to map.

Here you go

Does this happen only in Studio?

1 Like

I have been having the same issue in one of my games, it’s a big pain. It happens both in studio and in-game. The images were loading fine a week or two ago, but now a bunch of them just won’t show. I get these errors in the output:

I sometimes also get an error that is essentially “asset with empty-string-URL failed to load”. This happened in another place recently where my shirt was failing to load – I fixed it by manually setting my ShirtTemplate URL using the developer console.

Oops this is might be the wrong post to reply to given that they’re related to moderation – although the initial issue they had where assets stop loading sounds familiar.


I thought I was the only one. This may be a moderation issue, but a bug at that… a moderation bug. We ended up just removing the elements, that used the images, from our game. We also gave up because it’s an actual wall in our way, and someone else is holding the hammer.

Nevermind, in our case one of my teammates renamed the assets in the game explorer, and we were using game assets as the asset URL. Never use game asset URLs, kids.