! Important Notice on BodyAngularVelocity

For what it’s worth, I would prefer the term Assembly be used in the future over Body. While it’s not an industry standard term, I think it makes more sense intuitively than Body.

Assembly to me calls to mind something like a Lego build, whereas Body makes me imagine a solid (a “rigid body”).


“Body” Makes more sense more than “Assembly”

1 Like

Oh well that’s a rip for a lot of vehicle games.


I have a strong grudge against a lot of the contraints given how restrictive they are over the old joints classes such as Weld, Hinge and Rotate.

Naming a property BodyAngularVelocity will destroy backwards compatibility and I suggest you rename this property to a new name.

It’s not.


Pretty sure I was told that the old BodyMovers are not depreciated as they still provide additional functionality - most notably maxTorque is a vector in BodyAngularVelocity, but a scalar in AngularVelocity constraints, same with maxForce in BodyPosition. If BodyMovers are being depreciated, can we have this functionality added to the constraints system?


Will be useful in physical model things in, yap’ hoping won’t be failed for sure.

1 Like

I disagree on this point and feel like Assembly is more descriptive than Body, as mentioned in previous replies.

After asking a few non-Roblox people, the word assembly seems more like a collection of singular things to them than Body does. Body, to them, seems like another singular thing, and not a collection. My sample size was low at 4 people, but seeing as most dictionaries also agree…

The terminology not being common on the platform, or not documented enough on the platform, does not seem like good enough reason to avoid it either. As a counterpoint: Will this post & the potential name collisions caused by this change be documented and easily available for years to come? Will new developers who might stumble upon legacy BodyMover objects know about it?


I have to agree that Assembly makes more sense for its purpose than Body does, especially considering the word Body has never been used for developer-facing API outside of BodyMover classes. If that name were to be used instead, I’d consider that a better outcome than this, especially when I think about all the old, unmaintained games that’ll end up breaking due to this change.


I think Assembly makes more sense than Body. It’s easier to understand, and it keeps backwards compatibility with games that use BasePart.BodyAngularVelocity. Using Assembly instead of body sounds like a win-win to me :grin:

Also I’m glad to hear about new constraints and physics improvements, playing with physics is always fun


Just Rename it. (filler words here)


I like “Assembly” a lot better than “Body”. Not only does Body not make sense but it also has a name conflict. Assembly is the go-to naming convention for an “assembly” of parts so it makes sense.

As mentioned above, old BodyMovers still have their uses because new constraints do not provide the necessary flexibility to accomplish what you could with the old ones.


Only realizing after reading this thread that ‘Body’ is meant to reference a collection of parts. Like many others have said, ‘Assembly’ would convey the meaning you’re going for much more clearly in my opinion.


BodyMovers still make up a larger percentage of the Roblox active game universe. They have been used longer than constraints, are far more flexible than constraints, and have been replicated in models through games at least tens of thousands of times.

Adding a part property named BodyAngularVelocity, is a horrible way to make the game universe better. It will if it already hasn’t, break part of the functionality dozens of games active even today.

I imploy you to change change the property name. This is a matter that’ll impact not only playtime, but the Developer community, DevExing. Roblox Corporation income, marketplace and more.

EDIT: I’ve been making edits due myself thinking this property was about BodyGyro. Apologies for the initial statement being way off.


Yes, they would break. This will be sad, but I guess thats how it goes.

1 Like

I get the feeling that ContextLost et al. just didn’t realize “assembly” is actually a pretty known term in the community.

Does anyone have an example of old (free model or otherwise) legacy content using BodyAngularVelocity? I tried a brief look and couldn’t even find anything that uses it. Almost all legacy content uses BodyGyro for physics based orientation manipulation, not BodyAngularVelocity.

I think that BodyAngularVelocity and BodyGyro are being confused a bit here. If BodyGyro were potentially broken in this way we would absolutely have a problem and need to roll things back, however, it’s not. BodyAngularVelocity much more rarely used object.

And here I was cursing to myself why setting the velocity of a object had to be so annoying and inconvenient. Revolutionary, truly.

I have a model that uses it. I wanted to make particles “orbit” around a central core for visual effects, so I make long invisible parts centered on the origin with beams on the edges, and use BodyAngularVelocity to have them orbit around. I use BodyAngularVelocity as opposed to the constraint version as it allows me to do a per-axis speed to have more variety


Out of interest would Roblox be able to automatically rename and change all references to all existing BodyAngularVelocity objects to something else (a vague name such as ‘__BodyAngularVelocity’) before the update?

This would likely prevent most old games from breaking.