Is this a bug or i did something wrong?

Hello everyone!

  1. What do you want to achieve?

I want to use IK in my custom rig without any problem, like this:

  1. What is the issue? Include screenshots / videos if possible!

Im having some problems with the animation editor, i need to use IK constraints on a custom rig
Video of the problem:

Im not sure if this is a studio bug or i made my rig wrong

Here is how is it rigged:

-Need the model? Here it is: Squidloon2.rbxm (58,8 KB)

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I tried searching here for similar posts and i searched in the DevHub for a solution, but nothing…
This also happens to me with EVERY custom rig that i made and supports IK

Please, if you found the problem, let me know what happens and how do i solve it (if you can determine what is happening), because, as i said before, this happens with every IK rig that i make!

Thank you!

ah yes the classic most common issue where the parts refuse to operate its most def an issue of rigging the parts wrong go over your rig one more time

What do you mean?
I don’t understand…

what i mean is u rigged the model wrong

So, i need to re-rig it?
How do i rig it rightly?
I rigged it like you rig every R15 rig
I don’t know what happens…

could u show me the rig connections in the explorer tab i just wanna be sure if you have the parts u actually need

studio is refusing to open for me so i cant check it on my own

Its a very fun strory, my rig has lots of parts and joints :sweat_smile:

Try changing the name from Maintorso to Torso image

Still not working

Have you looked into this yet?


give me some time imma go over ur rig on my own rn just to check what the issue could be

ok, so you don’t need the screenshot of the explorer?
Because it has lots of joints and parts

EDIT: I need to go right now

oh ik constraint custom rigs don’t rly have support for it well you could
select the parts u need
and then rotate the once u have selected

also my bad saying it is rigged wrong its rigged perfectly fine
just didnt see the ik constraint you mentioned cuz ye as i already said custom rigs r wack w ik constraint on roblox studio

1 Like

I could see that your rig IS NOT A SKINNED MESHPART.
I asked if you’ve seen the update that allows them and wondered if you’d be interested.

Forgive me for trying to suggest something that you might like to check out.

You should try to use MoonAnimator to rig your parts(although you dont have to).

You would select one part to rig to the other:

But, this problem still occurs, so, what you do is you use RigEditor to fix it:

What you do in the rig editor is you move the ends of the yellow dots to where the parts intersect.
Now the problem is non-existent.