[Live] Changes to Game Passes


Just in time for the weekend; thank you

EDIT: It appears PromptGamePassPurchaseFinished still isn’t working, at the very least in test servers in Studio. Also after they buy it, calling “UserOwnsGamePassAsync” doesn’t work until they leave and rejoin.

Them buying the gamepass doesn’t cache properly on the server yet. If I call “UserOwnsGamePassAsync”, I think it grabs a cached version. I’m using Player.Id and the proper gamepass Id as arguments as well.


We are deploying a fix for this bug in the next few days.


Test purchases in Studio do not appear to fire any of the new events which makes testing gamepasses frustrating.


The event appears to fire fine for me: Repro.rbxl (14.0 KB)

Can you verify that it works in this repro file? If it does, can you create a minimal repro file for the new events not firing and attach it to this thread?


Over the last 24h I’ve been getting A LOT of messages and wall posts about gamepasses not being added to their inventory, but them losing R$ on it.
Anyone else? I’m using the new gamepass features, and they worked for about a week before this issue started occuring.


It’s likely their purchase didn’t actually go through, player reports are always terribly worded and confusing.


I bought the swords in your ninja game yesterday. At first I thought it wasn’t working because it took 15 seconds between when I clicked “buy” and when the game pass dialog showed up. Once it appeared, everything worked fine, but I was surprised.


Unrelated, that ninja game is really fun.


In testing (both local server and online) I don’t get that delay, so maybe it was an anomoly? (I prompt for purchase via remote event + serverscript)
I am using the new GamePass features since you can’t use the old system anymore.

btw, glad you love the game :smiley:


Hi, just one question.

How can I get the Image Endpoints for the GamepassId.
Previously, with the AssetId, I could do
But now, I cannot figure out how to do it using these new IDs.

@RuizuKun_Dev appears to have the same issue as described in this thread

Developer Hub Game Pass Confusion
Gamepass images
MarketplaceService:GetAssetInfo doesn't work on game passes- any alternative?

It has been filed as a bug internally. Thank you for reporting it!

API for retrieving gamepass icons

Disregard, I was being dumb and didn’t connect the event properly (what a surprise). Sorry for the late reply.


I found another bug. I sold a Game Pass to another game inside of my game and I got the commission, but on the sales page it showed a link to something completely irrelevant.

which leads to https://www.roblox.com/library/4422298/Coolest-Brick-Around

but it’s supposed to lead to https://www.roblox.com/game-pass/4422298/Rainbow-Trail


Inexplicably tons of people have been messaging me about their gamepasses not working
The server does a check for the gamepass upon re-entry and adds it to their inventory if it’s missing.

It’s been working for ~3 weeks and all of a sudden since a day ago or so it’s been inconsistent for some reason. People buy the pass but never get their items, even when they re-enter.
And it’s really hard to figure out why this is happening.

EDIT: had a live test of someone buying a gamepass, it seemed to work fine then. I think people are rarely being charged during high traffic and not actually receiving the gamepass on their profile, when there’s really nothing I can do about that.

Re-entering the game essentially “recreates the inventory” by checking a bunch of things, so it might not entirely a saving malfunction (to my knowledge! I’m still trying to get in contact with people who told me about the gamepass glitch and push them for more info)


Any update on this? I’m trying to get the image of a gamepass, and using :GetProductInfo() returns a 0 for the IconImageAssetId.


I’ve been getting this error today:
MarketPlace:UserOwnsGamePassAsync: Parses invalid JSON: Data may be corrupted

I haven’t updated anything gamepass related lately. Is this on my end or API?


How does it show the USD icon next to the robux. Is that a plug-in?


I got this error yesterday too.


Could you provide a test place that can reproduce this error? Thanks.


I’d love to. But this bug does not happen 100% of the time. So I can’t provide a test place where this bugs is reproduced. It’s like when the datastores fail, it only happens occasionally.


I’m still getting this. It only happens like once per 5000 sessions so it’s not a big problem but thought I’d share the pseudo-code anyway:

local PASSES = {
	["Speed"] = {
		id = 4596243,
		price = 100,
	["Radio"] = {
		id = 4596250,
		price = 250,

for k, v in pairs(PASSES) do
	if MarketplaceService:UserOwnsGamePassAsync(uid, v.id) and player.Parent then
		-- stuff

Message: MarketPlace::UserOwnsGamePassAsync: Parsed invalid JSON. Data may be corrupted