Mac OS Mojave - Studio Freezing

In the past three days, it has become extremely difficult to use Studio on my macOS Mojave, 16GB RAM, 2017 MacBook Pro. Typically Studio runs just fine, with no performance issues give or take a few minor crashes every once in awhile.

But three days ago it started to get worse- it would slow down as I began typing into the script editor. Until eventually (today), getting stuck on the spinning color wheel of death, loading one character I’ve typed every 22-23 seconds. It’s absolutely frustrating, so I decided to try and use other devices I have around my house to see if the problem was localized to just my laptop.

Unfortunately, all other devices that I tried (all macOS Mojave systems, with close to the same specs as my laptop, give or take a couple GBs of RAM) had the same issue, just not as bad as my laptop. Then I thought this could have something to do with being in Team Create, so I tried opening a Baseplate file on my character and the same issue came up again (across all devices).

Also ran a couple of network tests, and my internet runs fine and dandy.

Some help would be greatly appreciated :smile:. Thanks


I’ve posted a similar issue here. Sometimes Studio doesn’t even startup, it just jumps straight to an unresponsive state with no windows open.


Yup: Can confirm that it’s happening again for me too, except that this time its lagging in Studio when I move around. Graphics are on lowest setting, both in studio and in game. Yesterday, this wasn’t happening and its getting very annoyingly hard to build as the frame-rate is very low. I’ve tried closing all my applications, and setting the colour to Generic RGB, however both don’t reduce the lag.

I have a MacBook Pro Mid 2014, on Mojave, running at 16 GB (Memory), Intel Core.
As said above, it was working perfectly at a reasonably high setting without any lag so it can’t be my settings (I assume).

Could anyone follow up?

Can I just ask what your exact processor & graphics card, if it’s in there, is?

Also, have you guys tried changing your graphics renderer to Metal or Vulcan? Not sure if DX11 and DX9 is on Mac, but if it’s an option, try those too.

1 Like

Can relate overall, the studio is extremely laggy these days. Running the play test takes like 20 seconds…


Graphics is Intel Iris Pro 1536 MB

Hey, I am having the same issue, really gets annoying. I don’t think it is the graphics, because this just started about a week ago, but before Studio was fine.


Processor: 2.9 GHz Intel Core I7
Graphics Card: Intel HD Graphics 630 1536 MB

Both of your processors sound fine.

Have you guys tried changing your graphics mode?

You can do this by going to File -> Settings -> Rendering, and scroll down to “Graphics Mode.”

Change it to something like Vulkan or Metal (if you haven’t already.)


Tried both, neither setting works.


Unfortunately- the same for me.

After going through and removing all Roblox and RobloxStudio files throughout my entire laptop (~/Library/Roblox, and User Library/Roblox) and reinstalling, I was able to finally get it to run smoothly on my laptop. @Hadiisepic @TheRings0fSaturn

It must’ve been a bug that was occurring within my version of Studio?

1 Like

Possibly, I’ll try that and let you know now.`

EDIT: Finally, its not lagging anymore. It must of been a bug. Not sure exactly why or how it started though.


Yeah I’m also unsure, but for now I’ll mark it as the temporary solution I guess.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.