Making a mesh shadeless?

I plan to use a special mesh with an inside out sphere to create a sky for maps but it seems to produce a large shadow that breaks the illusion of the sky being vast:

changing it to forcefield with -100 transparency fixes the shading issue but strangely particles become invisible randomly:

what can I do? I want a shadeless mesh but also don’t want particles to cut off like this.

1 Like

I would suggest making the fog end lower and make sure the mesh has its transparency set to 0. change the fog color to match the color of the mesh.

My Results



Transparency = 0, Fog End = 4000

that would mean I would have to change the fog color and size whenever a player enters a new area with a new mesh tho wouldn’t I?

1 Like

I think you can change in lighting a property that I don’t know how it’s named, but it was something similar to “Color bottom”, change it to 255,255,255 (White), or change the brightness to a higher one.

I think u mean ambient light, and looks like that solved the shading issue with the mesh.
but due to this shadows under parts are now brighter but I suppose that’s an ok tradeoff.

1 Like

I think another solution would be change the material of the mesh to a neon, and set the color to a dark light blue, similar to this, I guess:

When the color is more darker in a neon object, less bright the item will be, but will keep the effect of no shadows, I guess. Try to play with the color and you might get it.

I noticed that the mesh Im using wont display most textures, I can change it to forcefield but not really to anything else.

its a special mesh with a sphere mesh turned inside out.

Here is a way to achieve that effect, but requires some Blender knowledge:

1 Like

so essentially just make the sphere mesh shadeless in blender then reupload it to roblox? I thought things like shading and color were not preserved when fbx files are uploaded?

I’m not sure about fbx files, but it works with obj files. Just point the normals down instead of up, after flipping them for making an inverted sphere.

I tried it myself, and it was a little tricky.

It creates this darkness when intersecting with the baseplate, and my only solution for that was to make it massive:

The material in both images is plastic.

you don’t have to go through all that trouble to get it inside out u can just use (-1,1,1) in the scale property with the special mesh object.

and also, last I checked there’s an option in blender to just change a mesh to “shadeless”(new material > shadeless), will this work to get it to appear shadeless in roblox or do you still have to do the above?

edit: nvm shadeless option does not work, im updating blender so I can do what you mentioned.

due to not having a good enough graphics driver I cant run blender 2.8 and above, is there a way to do what you describe with 2.79?

Here’s the MeshId: rbxassetid://4908271118
The original dimension is 2x2x2, so Scale in SpecialMesh is doubled.

1 Like

thanks, but just curious, do assets on roblox ever get deleted? I only ask because using assets I didn’t create makes me nervous because idk if they can be removed at any given time.