Meshes not importing

So, I’ve been working on a game. However, when I try to import a mesh, nothing happens and it zooms in the mesh part but the object didn’t actually get imported.

Unable to publish MeshPart: HTTP 404 (Not Found)
Error while creating named asset: Could not upload MeshPart

That’s the error that pops up and I have tried changing the name and the same thing still happens and it was working fine yesterday so if anyone knows a solution please tell me!

(Note this only happens when I am in a team create and nobody in the team create could import a file.)

6 Likes

I’m having the same issue right now at the current time of 8:10 p.m. est. Instead, Roblox just crashes, without even showing an error display.

1 Like

You may need to resize the mesh. If you’re using blender, then you should be able to scale it to real life size. You may also need to make sure the mesh file is an .fbx file when you export it, otherwise it won’t work. @2Dude4613

4 Likes

@Cadxsan I still cant import it.

Open your game manager (In view tab), right click on meshes, click open meshes, and go to your files to select your mesh. After opening the mesh, check off the top 2 options and click apply all. After they have all been resized, you need to go back to the game manager and select all of the new meshes. Right click on them, and click insert with location.

Hi, scale shouldn’t be a problem when importing a mesh. Also, .fbx isn’t the only supported format. E.g. .obj (wavefront) works perfectly fine as well.

As it seems, stated by the topic, this issue only occurs in team create so I doubt it has anything to do with mesh formatting, size etc.

@hundrethh
Have you tried re-opening / restarting team create? If not you might want to do this. Or you could try and move everything to a new place. I’ve had a rare bug before where one place was absolutely broken and wouldn’t let me do anything. This was easily solved when I created a new one.

Hope this answers your question!

On a side note, I just realized this post is pretty old. It popped up in recent so oh well :rofl::sweat_smile:

3 Likes

This post is pretty old however, I realised another way to fix is to make sure you tick selected objects when exporting.

im having the same problem rn, it works when i do it with a meshpart but does not work when using the import 3d feature. i tried every way, i dont know whats wrong with roblox