ModalEnabled not working

Easy to replicate. LocalScript, inside any of the clients stuffs.

UserInputService.ModalEnabled = true

Doesn’t do anything.

There’s been no announcements on if this has been deprecated (no reason why it should be!) and some transparency would be greatly appreciated


Can confirm. It hasn’t been working for me for a while too.

Can confirm: it doesn’t work with me either.
I made a post in scripting support and people tried to help, but it was no use. It didn’t work no matter how hard I tried.

(here’s the post by the way: Help with UserInputService.ModalEnabled)

Can we get some sort of word on this? There’s no work arounds for this and really slowing down any work I can do

1 Like

There are already lots of Platform Feedback threads and discussions involving how ModalEnabled is finnicky due to the way it’s registered.

A lot of these are either old or got no solid answers

You’re free to add a reply to any of those threads. It’s not considered a necrobump if you add a response mentioning that the feature is still bugged or have information to provide. This is also much better than posting another thread on an issue that’s already been reported many times.

No official bug reports have been filed for it in the past few months tho

These are all valid bug reports. ModalEnabled still does not produce intended results if set early, meaning that all of these bug reports are still relevant and valid. Post a reply to these threads rather than creating a duplicate topic for an already-reported issue.

Also having this issue. The difference from past issues is that now it doesn’t work at all. All of my uses of this currently seem to do nothing where they used to before, both in-game and in studio.

1 Like

@colbert2677 posted a specific workaround for this issue:

I’ve been using basically the same technique for as long as I can remember due to the
flakiness of ModalEnabled.

This hasn’t been working for me either, and it’s very frustrating. I hope they get to fixing this soon.

Not a very constructive reply.

ModalEnabled has been “broken” for over 5 years now. As for the current PlayerModule scripts (the ones that implement your camera and your controls), they do not incorporate ModalEnabled at all, making the property completely useless right now.

You will need to use a workaround or fork the PlayerModule so that ModalEnabled works with it. Make sure, when doing this, that you also add an initial state check and set up controls based on the value, then check for changes and toggle as needed. This is so that scripts running earlier than the PlayerModule’s loader (e.g. those in ReplicatedFirst) don’t need to rely on weird hacks to force it off.

1 Like

Info here on the upcoming fix (link updated)


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.