Models not appearing

Hey fellow developers! So it seems that when I was building, this morning everything was perfectly fine, I could see all my models and such. Now when I join and try and build, some of my parts/models seem to be invisible. At first, I thought this was due to my computer, but it was the same on my other developer’s computers too. So then I tried figuring out the source. Then I thought, oh these are unioned, maybe if I union them they will appear. However, I did this and nothing happened. The models were still invisible.

I don’t know if this is a Roblox issue, such as one of the many updates today had a “Flaw”. Please tell me if any of you are having a similar situation. If any of you know how to fix this issue I would really like to know.

Here is an example of what I am talking about.

As you can see, the doors seem to be invisible and so are the walls.

I assume the models/ parts that are invisible unions?
If so they might be corrupted.
Here’s a link that will be able to help you solve this issue. How to recover invisible / corrupt unions

1 Like

I don’t really know how to fix this but I do have an idea.
There is a property called “archivable” which could be the problem.

Thank you so much for this tutorial!

1 Like

This could be due to data loss from unions. Try to un-Union the parts and see if they appear!

This is why I suggest not using unions for bigger projects just because of this reason, they tend to corrupt/disappear sometimes when working. I’m not sure what causes this to happen but use his tutorial he linked and recover your corrupt unions.

Are they built in studio or modeled in blender?


Yes, I already have tried that. It still seems that they still are invisible.

Everything was built in studio.

1 Like

The thing is, that I have been using unions on so many of my projects, and they work perfectly fine. I will be using the tutorial to recover the corrupt unions later.