"Modern Studio" (new docking behavior) has various issues

Before re-installing Studio, I got this message and it was still happening. Re-installing has completely solved all my problems with the UI.

I have a specific bug for this for almost 2 months now:


Love knowing that even though a ‘fix’ was implemented, that this isn’t an actual button. My output window has now perma-docked itself above my secondary monitors bezel meaning that it is stuck there no matter what I do.

Is there no way to add a button to reset all widget positions as a temporary fix until this bug is actually patched?

1 Like

Hello — just a quick update to share, with suggested fixes, on this issue:


Yes - see above post from Paul


We would like to beta test fixes for the 3d view/toolbox undocking problem. Unfortunately, without an internal reproduction we need help from users who are willing to beta test our fixes. Please DM me if you are

  1. Facing a problem with your layout undocking (ex. the 3d view or toolbox is undocked and placed at the top left of your screen)
  2. Willing to beta test a fix to resolve the issue

Ever since I got the “corrupted layout” dialogue, I haven’t noticed my viewport getting undocked. However, I am willing to test any beta fixes you might have, if you need me to.

I will also let you know if my viewport undocks again.


was going to send a message to @Bug-Support until i saw this topic
the toolbox is literally having a stroke, every time i open a place the toolbox keeps appearing at the top left, and when i move it the toolbox also goes to the toolbox (since both windows are merged)

1 Like

Sorry to jump in here.

I used to have my 3D view undocked on a 2nd monitor to edit UI in full screen.
However, my 3D view recently reset back into the middle and I can’t seem to make it pop out again.

Is this a related issue or am I missing a button/shortcut to do so?


1 Like

I believe 3D viewport undocking has been locked for a while now, in order to reduce layout issues caused by it. This is temporary, though.


Correct. We are working very hard to restore this!


This seems to be fixed now!


Hi everyone,

We believe we have resolved the remaining issues of layout corruption with release 560. Please update your Roblox Studio and let us know if you continue to face corruption of your layout (for example, a widget or 3d view being docked to the top left and unmovable). If your layout was previously broken, it should now be fixed.


I am still having these issues.

Specifically: The one where your game viewport just docks outside of studio and you can’t bring it back in. Happens sometimes when I try to play test or just launch studio. The bug is inconsistent and I don’t have a reproduction method besides it just happening sometimes.

1 Like

Thanks for letting us know. Yes it is extremely inconsistent which is why it has been so hard to get permanent fixes in. We do have a solution for the problem when running a Test session that should go out soon. There’s also known issues with running multiple Studios on machines that are prone to this problem.


I have received this several times, I have also tried the reset layout as also suggested. It is still repeatedly happening on a regular basis.

1 Like

Just thought I’d bring this back up.

I posted about this in November 2022, and it’s now the middle of February 2023, and I’m still having these issues - it stopped for about a month in January, all of a sudden now near enough the majority of times I load up studio I have this issue - and now I’m getting it effectively whenever I load up the animation editor - a Roblox plugin.

This is getting ridiculous now.

Hi @AstraI_YT I’m sorry you’re having this frustrating issue. This is the first I’ve heard of Animation Editor being troublesome so thanks for the report. I’ll get this to the team.

Please know that we have been working very hard to chase these issues down. They have been very difficult to reproduce (I know it’s hard to believe when you personally experience it consistently) and there’s not a single, simple fix. We are also working on a permanent solution to resolve the root causes… which is a major undertaking that can’t be done quickly.


UPDATE : This is not fixed as of 2/15/23. Looks like there’s been a regression.

From what I’ve seen it’s possible to fix with deleting a registry file. Hopefully if someone sends a corrupted registry file you will be able to reproduce it.