My UI Isn't appearing while the Visible Property is true

why the scale of the ui is 10000,1000 for x and y

1 Like

That’s just to make sure the UI fits the whole screen. My computer monitor Isn’t big enough to know from studio.

Bro, just do 1, you did 1000000 (100,000,000% of your computer screen).

3 Likes

t make the ui full screen just 1,0 for x and y

Yeah I just tried and it still won’t appear. I set it to 100 for both X,Y.

2 Likes

Also, you only need to do scale if you want it to fit the whole screen for any devices. (1,0,1,0)

1 Like

maybe you should learn from @Quwanterz instead of me

Yeah I just tried thanks for that useful information. But the UI still isn’t appearing?

Thanks For Trying :slight_smile:

1 Like

Are you sure? Can you please show the new UI property?

Is the ScreenGUI Enabled property set to true?

1 Like

It says visible and I even input the same size numbers that you gave me.

Yes Indeed it has enabled set to true.

I’ve even set a print(“Completed”) for debugging reasons and it has been printed out. Its placed after the Events been fired

  1. Why are you setting the UI to enabled in the server?

  2. Setting the visibility in the StarterGui won’t change to the player’s, the GUIs will get replicated to the PlayerGui in the Player service. Did you set the visibility of the GUI from the player’s GUI?

4 Likes

I’ve tried multiple ways including you’re suggestion. It just has the boolean true for the visible property and I really don’t know why its not appearing? One more thing to add is that this issue started happening to me today. Couple other days the same code I’m using right now worked perfectly.

You really didn’t answer my questions, may you please answer them?

Yeah I stated I’ve tried multiple ways including you’re suggestion, I apologize for the misunderstanding. And for the 1st question I didn’t really know that it mattered that It’s set to the server.