Need help with lights!

Please, do not be mean to me, I am a starter developer and I really want to start becoming a good developer.

One thing, that was a bit confusing to me, how can I make the lights in the room precise so the flash won’t go outside the walls.

Thanks in advance,
lovelysalad :slight_smile:

6 Likes

lights_issue_

This is what I mean.

First ensure that Shadows are turned on for your light objects.

Then, you might have to adjust the thickness of the walls. This wall here is two studs thick.


This one here is six studs thick.


Lighting works on a 4x4x4 stud voxel grid (unless that’s smaller now? Correct me if I’m wrong), so sometimes Parts thinner than 4 studs will have this bleeding effect.

Until new lighting systems comes out, there isn’t much you can do.

11 Likes

Thank you for your help, I find this very helpful and I will experiment this now!

Also, are there any plans on the new lighting system or?

Wait I thought future is bright was released?

I really do not know, sorry! :frowning:

As I stated before,

I’m pretty sure only the first phase of Future is Bright has been released but I might be wrong. (The announcement post mentions phase 3 as “crisp lighting and shadows from local light sources such as point & spot lights” which hasn’t happened yet.)

2 Likes

If you want the voxel lighting system you need to go to your lighting’s setting and change “legacy” to “voxel”

1 Like

Voxel will not solve this issue (yet, hopefully phase 3 comes soonish) and that’s not what the post that he was replying to said.

1 Like

They were unsure if voxel had been released, I was just informing them it was available but had to be manually switched over.

1 Like