No popup windows will open in some places

A lot of popup windows in Studio just won’t open in some of the places in my universe. I can’t open the “Publish to Roblox as…” window nor the “Save to Roblox as…” window and I can’t open the “Game Settings” windows. I get no errors, “Publish to Roblox” and “Save to Robox” both work fine. When I try to Save as or Publish as I can see in the output window that it auto-saves to my device but then does nothing. I can click the button or the keybinding as many times as I like and it will do nothing but auto-save over and over every time I press it.
In some places in my universe that I haven’t made any changes to recently, these windows work fine but for others, the buttons to open them just don’t do anything.
I don’t know when this started happening but it was within the past month or so. I haven’t really needed to open one of these windows until now.

1 Like

New information: All places except the starting place within a universe have this bugs, even places I haven’t updated or changed since before this bug was a thing. So the starting place can open the Game Settings window and the Save to Roblox as… window just fine but all other places in the same universe wont allow these windows to be opened.
I need help

Found a work-around:
Save the place to file with “Save to file as…”
Close Roblox Studio.
Open Studio and open the locally saved file.
Then select “Publish to Roblox as…”
The window should open as intended, allowing you to publish your game.

While this works for getting around the problem, the problem still exists. It’s just a work-around.

We are unable to repro this in non-start places.

Please provide required information for posting bug reports

2 Likes

This happens in brand-new places with nothing in them.
A place I tested the bug in:


When I have the starting place “Bug Test” open in Studio and select “Publish to Roblox as…” it brings up the pop up as expected.
When I open one of the other places in the Universe titled “Noobot9k’s place number: 66” and try and select the same option in the File menu, nothing happens. I see it auto-save and then do nothing, open no window. Nada.

Working as intended:

Not working at all:

How to reproduce:
Create a new place and publish it to Roblox under a new Universe
Go to the asset manager>Places, right click and click add new place
Double click on the new place to open it in a new window
Try and click File>Publish to Roblox as… or Save to Roblox as…
Nothing should happen
The Game Settings button shouldn’t work either.
The game I linked to at the top of this post is copy unlocked if that helps any. It really is just an empty baseplate though.

Can you send us all log files from the time you open the first instance of Studio to when you close them all? Instructions are in the thread I linked earlier.

How are you opening these places? Through double clicking on the place in the Game Explorer? By clicking Edit on the website?

3 Likes

Sorry for the delayed response. I open the start place by either by clicking edit on the website or by opening it from the “my games” tab in Studio when I just open it from my desktop. I open the other in-universe place by clicking it in the asset manager/explorer seen in the bottom-left of the first of the two videos I sent.
Here are all of my logs:
logs_cantsave.zip (435.8 KB)

Update: The problem has somehow fixed itself… It was happening over multiple days so restarting my system didn’t do it. I’m not sure what happened but the problem seems to have gone away and I am able to open all windows as intended now.
Thank you for your time trying to help :stuck_out_tongue: