NPC animation, doesn't work

I’m making a Zombie AI and I search up how to make a NPC have normal animation(like walk,jump,etc) and it said to insert the player animation script into the NPC and I did that but when the zombie walks it has no animation.


It’s unclear to us what you have tried, other than you briefly describing it :slight_smile:
Please, what is the specific issue you’re experiencing? You should follow the format for the Scripting Support category, which you can see here: About the Scripting Support category - and the format to use:

To make it easier for us to help you, post the script you used here, and also show us the explorer of the model you’re using (so we can see the “tree” of it).

I just found a error and it says attempt to index nil with chat which is the mistake because the NPC isn’t a player.

You can go in run mode or testing mode, copy the localscript called “Animate” in your character that you are controlling, paste it in the zombie, replace the localscript with a normal one change some stuff like the zombie’s humanoid name may be different and the code will break, don’t forget to remove some non-necessary functions and properties that only players can interact with.


At the end of the animate script, there will be some functions that only works for a player.

yep :grinning: :grinning: :grinning:

Remove these functions and the one with the “chatted” event so it’ll fix the scripts, after you done that and it’s still not working can you provide us the output?

its working perfectly now without the chatted function

Okay, good to see. Atleast it’s fixed now.

1 Like