Odd mesh collision problems with mesh part

I’ve seen problems like this pop up every now and then on the forum here, and have myself looked at a few of them hoping for working solutions to this.

I’m not sure if this is a problem with blender itself or something weird

I’ve attempted to solve this by changing the CollisionFidelity to no avail. The player is supposed to touch the ground and not float on it like seen in the attached image.

Which CollisionFidelity options are you using? Also, if this is a really big mesh part (which it appears to be), the collisions won’t be as accurate on the normal CollisinFidelity.

Also, if you join the beta program you could try new the improved version:

Mesh collisions aren’t very accurate, unless you are using the new beta feature PreciseConvexDecomposition.

I would try using this, or instead convert the mesh to transparent parts, with the original mesh can-collide false.

I’m currently using the default option

I’ll take a look into that, using transparent parts would have to be a last resort due to how massive this map is.

Yep that worked pretty well. Thanks for pointing me there.