Parts of a mesh is hiding when I move away from it

meshparts
#1

So basically, when I was creating a mesh in Blender and inserted it to Roblox it gave me this warning where there is multiple parts in that one mesh, afterwards when I uploaded it to Roblox it gave me this weird quality screen where when I move far away a little it hides some of the Mesh Parts, has anybody experienced this before or anyone has a solution? Watch this: http://doy2mn9upadnk.cloudfront.net/uploads/default/original/4X/e/6/0/e60fa7dc4399422f3e55eda92a65412ce6812f65.mp4 (Sorry for the background noise, I forgot to edit that)

Thanks for reading.

#2

Hi there! I am familiar with the issue you’re currently having, but to be able to best assist you i would like to know what the mesh originally looks like in Blender. Could you send us a screenshot or .blend file by any chance?

1 Like
#3

Thanks for reading, maplestick, yes I’ll give you the image of the mesh right here.

I’m normally new to Blender so I was just creating a simple walkway.

#4

Your issue shows similarities with what another user experienced earlier this month. I have explained this in more detail here.

In short, faces can only be viewed from one side, which is the direction in which the normals are pointing to. Blender shows both sides by default, but if you were to put it in Studio, one of those sides will be invisible.

Here is a recreation of the model you tried to import into Studio. The cyan lines indicate the direction in which the normals are facing.

When you enable backface culling, the model will now appear as it would in Studio, with the opposite side of the faces made invisible.

If you only need the inside of the walkway to be visible by the player, all you need to do is flip the normals of the faces to all point towards the inside (i would also recommend cleaning up the mesh).

If both sides need to be visible, you will have to duplicate the mesh and flip the normals of these faces. Be wary that this doubles your poly count and is not advised for games with lots of meshes.

4 Likes
#5

Thank you so much for the amazing help! I couldn’t work through it without you, thank you! :grinning: