Player Camera seeing through walls?

Due to a recent roblox update, my character camera glitches through the walls and it really ruins my immersion. What are the steps I can take to revert it back to where the character camera no longer goes through parts like they are collidable.


Could you possibly share a screenshot with the angle this glitch is occurring? I believe I’ve been able to replicated it, however Roblox has always been giving me this anomaly.

For me, this only happens sometimes. I believe sitting in a vehicle seat can also cause this issue. Please provide more details, such as screenshots.

You can move over to the old player scripts and then revert back when the issue is patched. Make sure that the issue is reported on the developer forum or otherwise report it yourself, since you can’t expect staff members to patch it without it being filed properly.

Information on how you would go between playerscripts versions can be found here:

1 Like

Have no idea whats causing this but its soo annoying.

1 Like

I believe it’s another issue with unions and I have no idea how to solve it – unless its a CanCollide oversight or something simple like that. Did you try what buildthomas suggested?

1 Like

BaseParts have nothing to do with the issue. This is related to the camera script and how it is setting the camera’s CFrame.

I think it’s due to the new update involving smoother camera movement through petty collision that made the camera super sensitive. For your problem I would try a 0.95 transparent near-invisible block under the street. It should be a good makeshift fix for now.

What about buildings? It zooms straight through buildings that are thicker than 20x20

Here’s a related bug report, feel free to add any additional information you have there:


I don’t believe this is a ROBLOX issue, I think this is due to a custom camera script that you are using, as I’ve had this issue before. Make sure the camera’s target is the player’s Humanoid, and that the CameraType is “Custom.”

Its a roblox issue, trust me. If you want a fix, set your minzoomvalue to .5 which is the default. If you set it to anything other than .5 for the time being, it will break your cameras collision.

1 Like

See relevant discussion over at this response: