Player list is positioned higher up than normal

Issue Type: Display
Impact: Low
Frequency: Constantly
Date First Experienced: 2021-03-17 13:03:00 (-04:00)
Date Last Experienced: 2021-03-17 20:03:00 (-04:00)

Reproduction Steps:

  • Join any Roblox game that has the CoreGui PlayerList enabled
  • The player list should be positioned up higher than normal

Expected Behavior:
The player list is normally supposed to be positioned slightly below the topbar on the right side of the screen (see screenshot taken from the 469 release below)

Position of player list prior to the 470 release (screenshot was taken yesterday at 5:45 PM EST on the 469 macOS Client)

Actual Behavior:
After the 470 release, the player list is positioned slightly above the top of the screen and not below the topbar. This causes the “…” button to overlap part of the player list which blocks some of the leaderstats. The context menu that appears when you click on a players name appears to have its position slightly below the player that you clicked on instead of being next to the player that you clicked on.

Position of the player list after the 470 release.

Also, if you open the “…” menu, you are unable to pan the camera by right clicking and moving your mouse until the menu is closed, the tweens finish playing and the player list has reappeared.

The health bar also appears to cover the player list.

I am able to reproduce this in any game that uses the CoreGui PlayerList in the macOS client, in Studio on macOS and in the iOS app.

The screenshots were taken in Jailbreak along with most of attempts to reproduce this bug.

Update: RobloxGui in CoreGui appears to have IgnoreGuiInset enabled and if you enter Roblox Studio test mode and disable the IgnoreGuiInset property on CoreGui.RobloxGui, everything seems to be back in its normal position.


Also, the default Roblox health bar overlaps it.


I am experiencing this bug in all of my games as well. I also noticed it starting today.

1 Like

I also noticed this happening today.


The exact same thing is happening to me too. Hope this gets fixed soon.

1 Like

I found out the reason this happens. It turns out someone set IgnoreGuiInset to true for the entire core gui.
If I disabled it then it goes back to normal.


Can re-produce, happening in all games.

This is happening in every game I’m in too.
I noticed it around 7 PM.

Literally just happened to me a couple minutes ago when playing a game, just came on to the forums and I already see a post about it.

This problem also messes up the mouse position when in first person.

1 Like

Can repro. Re-stating here that if this is intended, please revert it. It messes up existing UI.

Another reply on a topic detailing the same bug:


I experience the same problem. I don’t know what is causing it. Maybe some new update that changed IgnoreGuiInset to be on by default?

1 Like

I’ve noticed this issue in many games, don’t know if this is the reason but maybe due to the resolution or refresh rate on your monitor?

Can confirm. Also it’s happening to Performance Stats and probably Micro Profiler too.

Feel so weird now

Someone set IgnoreGuiInset to true! All the guis no longer respect the topbar offset for some reason and its causing the mouse to glitch out too. I really need them to fix this!!!

See my response below:

Not sure why this happened in the first place :thinking:
It appears to be fixed now!

Thank you for reporting. This issue is currently being looked into.


This issue should now be resolved! If this issue is still occurring, please create a new topic for us to look into.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.