Roblox GUI removing itself?

So, in ANY game, whenever I enter the roblox “pause” menu thing, I don’t really know what it’s called lol (The menu that shows when you either press Escape or use the Roblox icon in the top left corner in a game), instead of going to the place with settings, reset character, leave game etc., all GUI, game related and roblox core GUI, gets removed. I cant see any GUI at all after I press that button. The game works fine, but I cant use anything GUI related. Nobody else seems to be having this issue, and while I do use RoShade a little bit, it doesn’t seem like any other RoShade users have this problem. Can anyone help?

If you need any screenshots, I will try my best to create them, as I don’t have any right now, but it is very easy to reproduce.

How to reproduce bug:

  1. Open roblox game. Any game. Doesn’t matter. As long as it doesn’t already remove CoreGUI.

  2. Open the Roblox menu. This includes pressing the escape on your keyboard, and pressing the actual button in the top-left corner.

  3. GUI is gone now. All of it.



its even worse now, my mouse is gone and i have to open and close the developer console (f9) to get it back.

also, whenever the GUI goes away, I can no longer move! I can see other players moving still, though. I also cannot turn my camera.

And now my camera is always turning until the GUI disappears, as if I was holding down right click forever.

Also, I’m thinking of restarting my computer but I cannot do that just yet as that takes absolutely too long (I’m on a discord call right now)

And now it’s fixed. I’ll leave this topic without a solution in case it happens again, but this is one of the most UNPLAYABLE bugs I’ve seen in the roblox client.

And it’s happening again. I guess it happens and then it doesn’t, then it happens again. I feel like restarting may be the only solution for now. It’s not happening on my phone, so I guess it might be RoShade or just my computer. My computer’s uptime is 14 days, so that might be it :sweat_smile:

I’ve had success with deleting the registry key for Roblox, so go do that. Follow this:

Except instead of deleting the RobloxStudio\LayoutSettings, delete the whole Roblox folder. This will cause Roblox to reset the settings for you.

This is a very obscure bug and is most likely because you are running out of RAM or a corrupted configuration.

Edit: Just noticed you had ReShade installed, this might cause issues with later client versions.

Didn’t work. I uninstalled and reinstalled roblox, and roshade is definitely gone, but the bug is still there. I’m going to try restarting my computer like I stated above now.

Restarting didn’t work yesterday, but now that I’ve reinstalled Roblox it seems to have worked.

The bug is happening again… Nothing works! I played some roblox VR games today, and RoShade is uninstalled, so it has to be Roblox. Is there a way to download roblox onto my D drive instead of my C drive? I think that might work.

You can copy the Roblox folder from the path %localappdata%\Roblox onto your D:\ drive. Then, go into the versions folder and launch “RobloxPlayerBeta.exe” in the correct version of Roblox.

I’ve done it with Junction Tool but the problem is still there, so I don’t think its about there not being enough space on my computer. I’ve uninstalled roblox like 3 times, doesn’t happen on my little brother’s computer, doesn’t happen on my phone, I can play just fine on both the Windows app and the Desktop app, but if I play from the play button on the website, thats where the issue happens.

Does the F9 menu still work when this happens? This is possibly an issue with the graphics driver or graphics card. Does the issue happen randomly?

The developer console does work, but I can’t move my mouse lol. All GUIs work, but when I try to open the Roblox menu they don’t work anymore and I can’t even see them.

Also all other non-roblox games work just fine. Only roblox has this issue, so I doubt it’s something to do with my computer.

That is very weird. You say it gets fixed if you reinstall Roblox, but then it breaks again after a while? This could be because of an antivirus program’s false positives or a virus.

The last time I uninstalled roblox and reinstalled roblox, it didn’t fix it, and then around 2 or so hours later i went to check on it to see if roblox had updated and hopefully fixed it, and it was fixed. So I joined the game I actually wanted to play, and then it thought I was in VR mode (VR headset isn’t even turned on) so I exited, rejoined, and it had the bug again.

I don’t think I have any viruses, but I’ll run a full scan. Afterwards, if there’s no detections, I’ll disable it for a second and run Roblox again, and if it works fine, then I’ll try to add Roblox to my exceptions or something idk (im not good with how antiviruses/antimalware work lol)

1 Like

It got fixed. I didn’t fix it, but removing the Roblox and Roblox Corporation folders from the Registry Editor app, that fixed it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.