Roblox LSP - Full Intellisense for Roblox and Luau!

Huge props, this extension is incredible. Moving over to VSC was quite overwhelming at first trying to figure out what extensions and tools to use for roblox - this handles all that hassle and has made writing lua code a walk in the park. Thanks a bunch for this!


Is “scr” there a typo? Pretty sure it’s supposed to be “src”

1 Like

What are the plans with Roblox LSP and Luau Typings? As I want to start using typings, I thought of using one centralized module that holds all types, yet when requiring the module and referencing my type as Data: Typings.PlayerData, Data seems to be any, as it can not find the PlayerData export within the Typings module.

There is actually no type checking at all, and I can’t implement it until I refactor the language server.


It just doesn’t do anything it worked before then just stopped do you know any fixes for this?

Seems to become an issue after Roblox Studio updated today


I haven’t been getting this error? :thinking:

Does the Roblox Studio plugin require script injection? The PopUp warning came up when I installed the plugin.

I don’t know if I am the only one experiencing this problem, but after the latest update the Roblox LSP extension seems to have slowed down significantly? I reverted to an old version and it works just fine.


Doesn’t give me suggestions anymore? Neither does it give errors and etc.

Can you show us your project.json file?

Files outside of src will not have any functionality from this Extension and if you put a "" at the end of a file path it will not work

1 Like

I’m doing single scripts, like modules. There isn’t a project.json.

Not very used to VSC extensions so I’m not sure if I’m the one doing it wrong.

I have installed both the Roblox Plugin and VS Code extension and yet it doesnt seem to auto complete the same way as shown in the video.

Do you mean that the instances in your game are not autocompleted? Do you have followed the instructions correctly? Use the same port, press the Connect button in the plugin.

When I try to connect, it would not go properly. I pressed multiple times and nothing had printed in the output.

Actually the plugin does not says when it is connected, it just says “Connecting”, “Reconnecting”, or failed to connect if it does not connect, do you mean absolutely nothing appears in the output?

You can also go to and check if it loads and if it’s blank or it has text, change the last 0 to the port you are using, by default it is 27843.

Yeah nothing appears into the output when I pressed it. I even tried to open the settings panel, nothing.

Make sure the plugin has the permissions to make http requests and script injection, it asks you when installing it, the script injection is because the plugin settings is an script, you can change permissions in the Plugin Management window.

Dont know what happened but now it seems to work?

And did you change the plugin permissions?