Roblox Rig Won't Work When I Rig it in Blender

I’m using a Roblox plug-in to import Roblox rigs into Blender for animation, and then export them back into Roblox. R6 works great, but when I try to animate R15, I can only drag the bones, the limbs won’t follow.

Video

https://i.gyazo.com/854aed42f464cfe0219b52212a3809e6.mp4

If someone could tell me what I’m doing wrong or not doing, please go ahead.
-TmsDevv

1 Like

Select both the rig and model, press Control P, then select with automatic weights

1 Like

I did and…

hmmmmmm, I never rigged things in blender that were parts based,
I think i’ve seen a couple youtube tutorials that focuses on that though, why don’t you look there?

1 Like

Might have to fix the weights yourself. Go into Object mode, select the mesh and go into Weight Paint mode.

(Screenshots soon)

1 Like

I don’t think weights are the problem, Im pretty sure there’s a different step when rigging stuff that’s parts based

1 Like

The plug-in I used had me “Rebuild the Rig”.
Plug-In post: Blender rig exporter/animation importer - Resources / Community Tutorials - DevForum | Roblox

Maybe this will help?:

If the rig is one mesh you might have to separate it using:
https://docs.blender.org/manual/en/latest/modeling/meshes/editing/mesh/separate.html

1 Like

I already tried that, it ended up glitching the rig, as seen in the screenshot I sent.

1 Like

I have no ideas either, sorry I couldnt help

1 Like

Here’s my idea on what’s going on, and how to (probably) fix it:


This is a quick “elbow rig” I made. However…


Yikes! Looks like Orange has melted a bit. Normally, we’d have to use Weight Painting to sort this out, but since we’re working with Roblox’s segmented rigid parts instead of something like a skinned, stretchy smooth rig, we can solve this easily.


Go into Edit Mode onto the melted part, and then in the Properties window, go to the Vertex Tab as shown on the right.

Remove any Vertex Groups that don’t belong to the part, such as “Blue Bone” here, via selecting the group, and then clicking the minus button.

To make sure that ONLY its intended bone controls all of it, select the Vertex Group of its intended bone, set the Weight to 1 in the same window, and press A to select all of the vertices of your melted mesh.

Then, click “Assign” in Vertex Groups.

Use Pose Mode to see if it works now!

(NOTE: A Vertex Group’s name MUST EXACTLY match whatever bone it’s referring to.)

1 Like

Um, yeah, way to complicated. The plug-in should do all the work, I don’t want to rig all this, I just want to animate.

Sorry, that’s the only way I know how to fix melted meshes.

Try just deleting the Vertex Groups that don’t belong to a mesh and see if that’s simple enough.

1 Like

It has nothing to do with weight painting just select both the bone and the part you want to move then control p and then parent to bone. To be clear you have to go to edit mode and then object mode to do this. This video does exactly what I said but visually https://www.youtube.com/watch?v=srpOeu9UUBU

1 Like

Um, I tried this, doesn’t seem to work, I need to select multiple parts of the rig to set them a bone. Why is this so dang hard.

You dont select multiple parts

You go onto edit mode you select 1 bone then go to object mode you need to make sure lock object mode in the edit menu is OFF