Roblox Studio closes when I play test it

  1. What do you want to achieve?
    I wanted to play test the game to try to find bugs and see if everything is working correctly.

  2. What is the issue?
    Whenever I press the play test button or press f5 Roblox Studio just closes without any pop ups.

studio bug

  1. What solutions have you tried so far?
    I tried restarting the computer, looked through the forum but the solution is to disable team create which I do not have enabled but it still closes whenever I press play.
    Everything else is working except play testing the game.

I just opened Roblox Studio today and it was installing an update but still did not fix the issue.

This is my most recent log files:
0.583.3.5831076_20230718T115926Z_Studio_1F10D_last.log (159.6 KB)
There are other log files too if you wanna see more tell me.


Is it only one of your places or all of them?
Have you put any free models or scripts into your place recently?
Have you installed any new plugins?

If your answer is no to the above try uninstalling and reinstalling Studio. There might be a glitch in Studio on your computer somewhere that the update didn’t fix.


All of them are affected


I did install a new plugin: (1) Reclass - free, intelligent class conversion - Roblox

But I don’t think that the plugin is malicious because I used it like a week without any issue before yesterday that the bug occurred.

@vieta266 Adding on to this, it would be good if you would also delete Roblox’s AppData files, and your Temp files.

Clearing Roblox’s AppData files

Both Roblox and Roblox Studio has to be uninstalled first!

  1. Press Win + R on your keyboard and type %appdata%.
  2. Go up a folder level (or just click the AppData file on the address bar of Explorer), and click on the Local folder.
  3. Find the Roblox folder and delete that.
Clearing your Temp files
  1. Press Win + R on your keyboard and type %temp%.
  2. Clear all files in the Temp folder.

After uninstalling it I press play and it seems to work the first try but after fixing some stuff I press play again and it closed. Now I suspect that a plugin might be the cause.


Update: I tried disabling every plugins I have installed and press play but Roblox Studio still closes itself. The cause of this might be something else.

1 Like

Now after all this I tried creating a baseplate place and Roblox Studio did not close. I think it’s something wrong with my game. I will try all the other places to see if they’re affected or not.

1 Like

There might be certain scripts in your game that causes Roblox Studio to crash. Perhaps, you can try temporarily disabling suspected scripts to debug this issue.


I tried 2 more places, one didn’t close, and one closes right after I press play. Strangely that place that closed Roblox Studio I haven’t touched in months, it used to have no problems before. I think there’s something wrong with Roblox Studio or something else.


I disabled every single script but it still close whenever I click play.

1 Like

You can try looking for similar topics, and try to troubleshoot with the replies provided in the separate topics.

If you still aren’t able to solve this, you’ll have to message @Bug-Support to alert them about this!

1 Like

I think it is because of the Data Store service, all the places I tried that closed Roblox Studio all have Data Store on so I think it’s the reason why.

1 Like

Oh, that might explain it. You could have been saving too much data in one data store entry.

1 Like

Never mind, it wasn’t because of it, it’s still closing Roblox Studio after disabling it.

1 Like

It seems like there is a similar topic which faces the same issue. You can try to follow the solution of that topic:


I changed the graphics mode from Automatic to OpenGL and it worked, thanks for everyone that helped!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.