Seams Visible With Custom Texture


I am currently experiencing a perplexing issue while working on a mesh in Blender, and I seek guidance to ascertain whether this is a software glitch or a potential oversight on my part.

To provide some context:

  1. I have been engaged in texture painting on a mesh in Blender.
  2. Following this, I proceeded with exporting both the mesh and its corresponding texture map.

However, upon applying the texture to the map, an anomaly has been detected:

  • From a specific distance, a distinct seam becomes apparent on the texture. A visual representation of this is provided here:


  • Contrarily, when the camera is zoomed in closely to the mesh, the seam vanishes. This can be observed in the subsequent image:

  • Texture Paint in Blender

  • Wireframe View:

Steps I took on blender

  • Smart UV project > Set Island Margin

  • Base Color

For further troubleshooting, I have ensured that no vertices are colliding or merging with each other.

Could anyone shed light on the potential cause of this issue? Is it a potential bug or might it relate to specific setup configurations?

1 Like

Roblox usually downscales textures. It might have caused visual artifacts.

To avoid this, try drawing the texture slightly over the UV maps.

1 Like

Due to making it a gradient I can’t manually extend the overlap to the seams itself due to color changes and matching with the gradient. I tried another way where I created a seam in the middle of the mesh and instead of the Smart Uv project I utilized Wrap but there Still was a seam visible.



Thanks to the suggestion from @IcyMonstrosity the issue can be resolved by increasing the “Bleed” value in Texture Paint Options. By doing so, no seams will be visible.

Step-by-Step Guide:
Under the Texture Paint Options > Bleed

  1. Navigate to Texture Paint Options.
  2. Locate the Bleed setting.

Full view of the Blender interface:

Close-up on the Bleed option to adjust:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.