[SERIOUS] Group gamepass page blank

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

I’m trying to create a gamepass for my group owned game, but I keep getting this blank page.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

Every time, just clicking on the gamepass group button

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.

Regular roblox website under the group develop tab

  • Would a screenshot or video help describe it to someone? If so, post one.

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

I wouldn’t know because I use the game pass tab once every 3 months

  • Anything else that you would want to know about the bug if it were your job to find and fix it.

Edit: 17 days later and im still getting the same results.
Only I, seem to be getting this bug.
Tried it with other browsers, seems to be a bug for only my group

Even tried creating a new account and letting them do the gamepasses but same thing

I can check gamepasses for all my other groups except this specific one

This is a HUGE problem since this is where i develop my biggest games and I just cant relocate as that would mean having to remake over 500 animations.

Also, I have a game thats 90% done, all It needs is gamepasses and this bug has halted development for over 2 weeks.


Can’t repro

1 Like

Please disable all web extensions on your browser and check again. I’m noticing R+ in the corner and you may have more installed that interfere with the page (i.e. adblockers, stylers, similar).

Only file web bug reports when you have double-checked that it happens on a vanilla setup.


Umm… yea I tried this a couple days later, still the same issue. Even tried it on my phone and It’s still blank. Other computers show the same result.

Someone please notice this bug

It is working fine for me, and I think for most of the people so idk.

I use Google Chrome and it works for me. I decided to go ahead and try other browsers to see if I can replicate the issue. On Firefox, Safari, and Microsoft-Edge the gamepasses appear.

It seems like it has nothing to do with browsers.

Is this the conclusion for me?
Only my account has this bug and I wont be able to ever create group gamepasses and badges again?

Update: It seems to work for all my groups except this specific one

Edited the description to show more information on the subject

This is really far from Roblox critical. Best remove the tag.


Its preventing me from advancing my game. Its not roblox critical for you but it certainly is for me

It is not subjective. There is a set of guidelines for Roblox critical and it does not meet the requirements.

1 Like

Are you still experiencing this issue? Does disabling any browser-extensions help? If you open the Chrome console (f12) are there any errors?

Considering it’s happening with the group alone and on every browser he tries, I think there’s something up with the group’s internal metadata, properties, or assets that is preventing the backend server from returning the gamepass data.

1 Like

Still experiencing the issue, tried disable all extensions,tried it on other browsers,mobile browsers, the Roblox mobile app itself and still the same results.