Some invisible part glitch roblox studio

Hello, so I have unfortunately encountered a glitch or something with studio.

So im basically creating a stadium, and i saved, published, and exited out of the studio. This is what it looked like before:

and then when i come back, this is what it looks like:

The parts that disappeared are still there, but invisible. I can select the parts that are invisible, but they have no transparency. Its really strange. Please help.

If it’s a union, set the SmoothAngle to 1 and it’ll reappear and then set it back to 0.

It’s probably an invisible union. It’s a common glitch.

Yikes, didnt work. It is a union though.

Yeah, but i worked pretty hard on that, is there any solution? Thanks.


If 1ik’s method didn’t work, then you might have to redo it. It happens a lot, and really, really sucks. If you want to stop this error from happening in the future, go to file, then studio settings, then physics and scroll down to disable CSGv2. That worked for me.

Basically, legacy CSG should be unchecked.

I’d recommend chwcking out the post 1ik linked. It has some requirements tho

1 Like