SOS Roblox studio cursor bug, impossible to use studio

Hello, first of all I’m going to say this is mainly a bug I’m looking for help on. I have tried many fixes and solutions I will let you know of all those shortly. I can’t post in studio bugs, so I don’t want to hear that this is in the wrong category, I want to hear helpful suggestions or someone that could pass this on for me.

Let me show you a video of what is happening as it would be easier to see.

Example 1 : https://gyazo.com/587a45e3cec58cad3f9bf5f0f6ce5d91

Example 2 : https://gyazo.com/9c5c90fd37d5ec3c536f8c633a4777b7

As you can see in the first example, my studio seems to always have a mouse cursor highlighting in the middle of screen, its like its fighting over 2 mice.

As you can see in the second example, when I am hovering my mouse over what should be nothing, its still highlighting parts that are in the middle of my screen. Even when I click its like I clicked and dragged to where my mouse is (the highlighting box, for lack of a better word, shows up, look closely)

I have tried reinstalling studio, restarting studio, restarting my computer, updating my graphics card drivers, this only happens in studio, I am sure this is a roblox studio bug, not something wrong with my PC, it does not do this for anything other than roblox studio, I have tried it in multiple studios, its not just this one. It does it in all of them. This makes it impossible to move objects and in theory makes roblox studio unusable. This happened after I reformatted my PC and had a fresh install of studio, since then it has been like this.

For those of you who are good with computers. I think it MAY have something to do with my screen resolution. I’m not sure, however I am on 1080p right now. Its just when my PC starts up, it starts in 720p for some reason, I’m not sure of. That started happening after I reformatted my PC. I have tried setting my monitor size to 720p and it still does this. Ive went through the nvidia control panel tried many different screen resolutions, aspect ratios, and scaling modes. Any help at all is welcome, any suggestions to try is welcome. I just want my studio to work again… thanks…

Might be your mouse that’s causing cursor problems.
Maybe change batteries.

I haven’t read your whole paragraph, so I don’t know if you said it wasn’t that.

It only happens in studio, with studio, its a wired mouse, no batteries, no problems with the mouse in any other programs besides this one.

Thanks for “trying” to help. However it appears you did not read my post whatsoever, or any of the posts you’ve linked. As I’ve said in the post I’ve done research and couldn’t find anything. Like all the things you’ve linked, not a single one of them has anything to do with the problem im experiencing. You should read before posting.

1 Like

https://gyazo.com/da8f7a83fda1deec5db7f8ced9504844
another example
ive also tried using another mouse, same thing

Looks like an issue with the lua dragger, since it’s new it has quite a few bugs to be fixed.
But a few things you might want to try:
• Updating any mouse drivers you have
• Going through any drivers for any input devices you have and updating them
If updating doesn’t work, try downgrading your mouse drivers. It could be a miscommunication between studio and mouse drivers.
What card do you have? NVidia drivers/cards have been having issues recently (these may be fixed, however I haven’t really kept up with nvidia recently) so you might want to try downgrading those as well.
What windows version are you on? I assume windows 10?
Since this happened after you formatted your pc, you might have a corrupt file or something like that. I’d try using microsoft’s repair tool to try and fix any issues. There are also ways to reinstall windows without removing any files, so if nothing else works you might just want to try that.

Will give all these a try and update

My gpu is a 2060, and yes windows 10

This is an issue happening all over studio. Do you have team create enabled?

No I don’t have team create enabled, it also happens regardless of what studio I am in. And this is happening for other people? I tried looking and can’t find anything

After trying the relevant solutions it appears to be happening less frequently, however still very much annoying, just studio is more useable

It should work if you turn on team create.

Turned on team create and it didn’t work, I also tried going into a group game that had team create on within the group and still no luck

1 Like