Studio crashes when attempting to update package

Strangely, this bug doesn’t seem to be tied to any particular package or even place; I made a minor change to another package in my experience, published that change, then attempted to “update all” from Place A. It almost updated, but Place B reached 5%, got stuck for a few seconds, then crashed the whole program.

I went to Place B, manually updated the package, made another minor change to it, published it, then tried to “update all” again (this time in Place B). Same result, it almost finished updating Place B, but Place A only reached 5%, stalled, then crashed Studio.

Again, this wasn’t the same “Common ModuleScripts” package that was affected by this bug before. This time, it was my loading screen package:

Update All consistently works if the only place that I’m affecting is the currently-loaded one. Therefore, the only factor that determines if it’ll crash when using the “Update All” command is if I try to update an unloaded place’s copies of the package.

2 Likes

Package ID: 13947352113
Experience ID: 10966411732

This is just one of the packages. All packages within this experience fail to update all. There are around 7+ packages.

The issue I am having is consistent with the behaviours experienced by @JoyfulFlowerMary @marinusss @TechnicalHost @CSJeverything

Here’s some other bits of information that may be useful. Whatever place opens the “UpdateAll” UI, can have its packages updated. However, the moment you try to update another place package, the bar gets stuck at 5%, waits a few seconds and then crashes studio with no error dialogue.

Update:
Noticed some slightly different behaviour. It seems like if a place either does NOT have that same package or is already up to date, then the update works fine (since no package needs updating anyways). However if the place does NOT have an up to date package, then it gets stuck at 5% and then completely crashes studio with no error message.

See video here:

The picnic and pixel minigame packages are up to date, however the flower place is not up to date and therefore crashed.

3 Likes

Not fixed, issue just started happening for me. Only crashes with one specific package, odd.

We have implemented a fix based on your reports - it’ll be in the next release in 2 weeks. Thank you for your invaluable contributions to help us improve packages.

4 Likes

Just wanted to check in: has this been implemented yet?

2 Likes

Yes, do you still see the freeze and crash issue?

1 Like

It seems to be partially fixed, Studio no longer crashes but shows this or stops responding for a while instead sometimes.

Update: I am no longer experiencing any issues with mass updates of a package.

Thanks to all the amazing people who have contributed to fixing this problem :heart:

1 Like

Hi,

It is partially fixed for me. Sometimes Update All does work fine.

However, Studio can still crash randomly when trying to run Update All. This time, however, right before a crash occurs, I notice that the waiting bar does not load, and my cursor changes to the waiting circle icon (Usually shown when a program/application is unresponsive or loading).

  • If I update a single place at a time, a crash may occur either straight away, or after I’ve updated around 5 - 10 places, one at a time via Update All
  • If I update all places (which is 30+ places), a crash will occur
  • If I update 5 - 10 places at once, a crash might occur

It seems like it is random, with a higher amount of update in one go causing a crash to be more likely. I have also checked if it was an issue with a specific place, however, I’ve found that after a crash, if I selected the same place again, it would update the place.

You are however along the right track! Just a few more bugs to work out.

1 Like

Update: The crash log contains actual crash information now! Also, I noticed an odd output that seems to be some sort of chat? Is that from Roblox Studio or a plugin?

0.591.0.5910633_20230826T013559Z_Studio_7D2BB_last.log (68.6 KB)

Update 2: Whatever is causing these outputs to repeat, seems to be what is causing the studio to crash. I tested this by leaving some time from opening the “Update All” window and then running the actual update. That odd output is in line with when I run the actual update all.

1 Like

I had just started experiencing this issue today. Whenever I run “update all”, studio crashes immediately as shown in the video here:

3 Likes

Same issue occurring to me too, suddenly happening for no apparent reason again.

2 Likes

It’s so annoying. I have to revert back to manually updating my packages every time I want to update my game, and it’s absolutely tedious. I wish Roblox would take notice of this issue more.

3 Likes

I am also encountering this problem again.

2 Likes

I filed a bug report to ROBLOX 3 days ago - they said they will notify me when they fixed it.