Studio not responding but not frozen - Mac OS X

I am trying to use Roblox Studio on Mac OS X 10.11.6 El Capitan. When I launch Studio, I can navigate the file menu or the various place-opening tabs just fine. Once I open any place (including a blank baseplate) Studio takes 30 seconds to a minute to respond to clicks in the viewport, ribbon bar, etc. IF it responds at all—a lot of clicks are completely lost.

I do not get a rainbow wheel, and the OS seems to think it’s still running fine, but Studio is completely unusable because of the lack of response.

If a place is open, the close/minimize/fullscreen buttons also take a significant time to respond, if at all.

If Studio is the focused application, it ignores any click on the “RobloxStudio” option in the menu bar, and interestingly, it also ignores clicks on the Apple menu (), however, I can click on icons in the top-right of the menu bar (volume, WiFi, Bluetooth, etc.) and they respond immediately. If Studio is not the focused application, the Apple menu responds immediately.

5 Likes

Have you figured out if this happens to anyone else other than you?

1 Like

Unless this happens to many other people, this is not critical. Please adjust your title as necessary.

2 Likes

I don’t have any way of finding out whether others experience the issue other than posting here.

Is there anyone who can clarify this statement?

I suppose this time around it’s not technically a crash, but it may as well be. I had a similar issue earlier this week and was told conflicting things about the use of the ROBLOXCRITICAL tag.

I love and respect the Roblox platform, but I honestly hate posting on the dev forum. It is very uncomfortable spending so long writing a post to ensure you have provided all the information needed and formatted it in the “proper” way, only to still have everyone point out what you did wrong.

I am a Roblox Developer who is unable to develop, and I just want help solving my issue.

1 Like

Sorry mate, these issues happen because you’re on an older version. I hate this as much as you, and I know how annoying it feels. I’ve used El Capitan without upgrading for a while, and I’ve had bugs worth every star in the sky. I’ve had issues with keypresses not recognizing lifts (no longer pressing the button), the completing breaking of certain features, etc. An upgrade completely eradicated all the bugs. Hopefully your machine allows you to upgrade…

Out of curiosity, does this happen with all plugins disabled?

I’m having this issue too on Mac OS mojeve, idk if its the os or the program but I really need to use studio and this is stopping my whole work flow, it happens 100% of the time for me and I know someone else who is having the same issue. I really don’t know what to do

This is still an issue.

I moved both the InstalledPlugins folder and the Plugins folder to Desktop and relaunched and the issue still occurs.

Roblox user Jay_Galt DM’d me on Roblox and said they are also having this problem.

An update on this: I went into Rendering Settings and I changed GraphicsMode from Automatic to OpenGL and relaunched Studio and it works fine. I’m not sure which graphics mode it was attempting to use, and I’m also not sure which graphics mode is optimal for my device, but this allows me to work around this issue. Hope this helps others with the same problem, and I hope it helps you guys fix this going forward.

This sounds like an issue that is not Mac-specific then. @yourock101 was experiencing a similar issue on Windows, where once he changed the graphics mode, the performance issues stopped. Could be a different issue, but sounds like they’re the same.

On Windows, this issue can be resolved by disabling VSync, but unfortunately on Macs, you aren’t given this sort of control from what I can tell.

I played around with the GraphicsModes a little more, and the one that is causing the trouble is Metal. Metal is specific to Apple products, so I doubt that it would be related to an issue on Windows, but I could be wrong. Perhaps somebody in rendering should be notified so that this can get fixed. Exact model is MacBook Pro Retina 15-inch Mid-2014 running Mac OS X El Capitan 10.11.6

2 Likes

You are right, I thought by changing to Metal it would be better but it is the worst. I couldn’t do 2 min before my studio would freeze.

Studio is now crashing 100% of the time on Windows 10, 64bit after clicking play solo.

We’re now in 2020 and this issue just started happening to me both on Catalina, and upgraded to Big Sur Beta and it’s still happening. Tho I’m 90% sure this is also a Catalina issue.

1 Like

While I was looking for a solution, I fixed this issue on mac, I pressed alt s to go to settings and I resetted the settings, that worked for me.

Try changing the rendering graphics all to one while doing it, after that you can change it again