Studio opens two windows upon opening

Hello everyone, several topics such as mine have been posted on the forum yet I haven’t found anything that works for Mac. And sorry for posting it in here, they took down studio bugs for some reason | is there anywhere else I can post it that’ll get checked by roblox staff?

When I open studio, i get a window that has the viewport and the baseplate and etc, ad the rest is the explorer, properties and all of the tabs o the top. I’ve tried redownloading, uninstalling all plugins, restarting studio as well as my laptop, nothing has helped to bring it back. I tried to drag it back into studio but I can’t click it at all, it’ll just open whatever window is under it. It has been messing with development and I would like to go back to scripting so if anyone (preferably with a mac, but any kind soul will do) has faced this issue or knows anything on fixing it I would greatly appreciate the help.


Now I understand, but I understand that you have a problem, right?

correct, the viewport window is separate from everything else and I haven’t been able to put it back in place.

a photo of whats happening

Is the problem on the device or on Roblox?

This has happened to me, but I don’t know how

probably the device? not really sure what you’re asking for here, maybe im not understanding correctly

You can read, but I speak Arabic because you are not Arabic, but because I speak your language

I had the same problem and I fixed/reduced the number of times it occurs by reinstalling studio. It now only happens every couple of days instead of it always happening. I hope this is helpful!

reopen studio about 2-1000 times, It happens every time now I have adapted to it

even if this is the solution, its still unacceptable for this to happen especially for software from a multi billion dollar coproration


I just got this issue too. I looked up some solutions and found one that worked. remember to not have studio open while you do this or it won’t work (i totally didn’t make that mistake) Windows incorrectly docking in Studio, malformed windows - #52 by SubtotalAnt8185

To fix the issue, you can try the following steps:

  1. Open the settings menu by clicking on the File menu in the menu bar and then selecting the Settings option.

  2. In the settings menu, navigate to the Rendering tab.

  3. Scroll down to the “General” section.

  4. In the “General” section, change the “Graphics Mode” setting to “Automatic”.

Click on the close button and restart your studio to see if the issue has been resolved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.