Studio's text is painful on an OLED monitor

I did not say the best option was an “idiot,” I said it was purchasing a new monitor. Sorry for the confusion.

1 Like

what’s going on in platform usage support

I’m sorry, I can’t help with that.

nah it was on sale for 999.99

this just started an entire argument :joy: :joy: :joy: :joy:

Okay, but no offense, have you tried what I said previously?

And this:

PS: This option is more favorable if you experience the same problem on other things than text.

1 Like

Increasing the sharpness didn’t really do anything.

I heard it doesn’t really work that well and that I should use mactype, BUUT, the problem is that studio uses an entirely different text thing to windows. All of the text on windows, chrome, and most things looks just fine. Like the taskbar text looks really good, but all of the text on studio looks really bad, and I think that’s because cleartype/mactype cant affect the text in studio.

yeah it didn’t help that much and I reverted it way before I made started the post.

Studio’s text is painful on an OLED monitor

Hmm… is it more like a sharp pain or a throbbing pain?

But actually I think your screen sharpness is too low like @yousefoyoy said

No, I tried putting the sharpness all the way up and down and almost nothing happened. The text didn’t change.


Certain CRT and LCD screens both have weird ways of rendering pixels. They’re circles instead of squares. My guess is that those are individual “pixels” on your monitor because the resolution of the studio application has not been updated to the new size of your monitor.

Check if your monitor is running in the recommended (native) screen resulotion, change sharpness option if possible in monitor OSD, and if the monitor has a pre calibrated color profile, install it
And also, re-calibrate Windows’ cleartype settings. My fonts looked bad (non oled monitor) until I messed with Cleartype

I’ve already tried all of that.

blalbalbalb

soooo how do I fix this, if it even is the issue?

You can either go to the settings of Roblox Studio and reset it in the Rendering section of the settings window (however in my experience this has a habit of not existing) or you’ll just have to manually change your resolution in your system preferences, the name of which will vary based on your operating system.