UI scaling problem

Hello Developers! I’m trying to do UIs, but there is a problem, for an unknown reason it doesn’t scale proplerly.

  1. What do you want to achieve? Keep it simple and clear!
    I just want do the UI systen more simple, as is difficult to do a UI shows like in studio at the game.
  2. What is the issue? Include screenshots / videos if possible!
    The problem is the size that shows in Studio is not the same at the game, in the game the UI goes whereever it wants, like it doesn’t shows like in studio.
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    I tried searching on the Devforum.

I’m tired of having UIs on any part, when in studio it shows where it should be, is more complex than it should be, I hope you can help me.

Kindest regards,

Can I please see screenshots of the problem happening?

1 Like



Make sure you have it set to scale, not offset.


Is ignore guillineset on? It makes the gui go through the roblox icons.

1 Like

What do you mean? Can you explain me it, please?

I don’t see that option, where is it?

This guide is phenomenal, I used it the other day and learned a lot.

1 Like

So there are two types of ways to define UDim shape and size. Scale, and offset. When it is set to offset, in studio if the screen is smaller, it will always be 5 pixels to the left, if you have it that way. If set to scale, it will retain the same position across all screen sizes

1 Like

Understood, I tried searching that option, I didn’t found it, sorry, where is it?

Go the the gui’s property’s, and find IgnoreGuillenset.

1 Like

In the properties, for position and size, the first {} is the X. {a, b} with a as scale and b as offset. The same is for the other pair which is Y. Here is the scaling plugin I use AutoScale Lite - Roblox

1 Like

I use Roundify, maybe is that the reason because it doesn’t appears?

It works with roundify? Or is just for normal UIs?