Unable to archive meshes that are uploaded as a "render mesh"

Reproduction Steps

  1. Upload a large group of meshes via “Import 3D” in roblox studio.

  2. Check the creator dashboard tab under meshes for the imported meshes. They most likely will not show.

  3. The mesh will not show in your profile inventory, however you can navigate to it via the pasting the ID into another mesh’s URL on the website.

Expected Behavior
I should be able to archive meshes despite being labeled as a “render mesh.”

This is one of my meshes that have been affected by this, it’s a part of a larger group of meshes for a character’s morph/armor.


Issue Area: Roblox Studio/Creator Dashboard
Impact: Low
Frequency: Often
Date First Experienced: March 31, 2023


We’ve filed a ticket into our internal database for this issue, and will come back as soon as we have updates!

Thanks for flagging!

This wasn’t an issue before the Creator Dashboard website update earlier this year- the archive button would be at the bottom of the configure page, but it’s not there anymore.
My RenderMesh is owned by me, but it does not appear in the “MESHES” section of the creator dashboard. This doesn’t appear in My Meshes in Toolbox, either.

There is also no workaround to access the old configure, as said here, it force redirects to the new one.

Unrelated but the most annoying thing, I tried to write a script to bulk archive assets, but it doesn’t run consistently because of loading lag

Hey just curious, what benefits does archiving a “render mesh” provide? As you pointed out, it does not show up in UIs, so how would it be different if the render mesh was archived vs not?

(reposting because I replied to the wrong comment, sorry)

Also I just tried this on my end, and it does not seem like Archiving the Mesh Part resulting from importing in AssetManager does anything to the RenderMesh of the archived mesh.

Because Import 3D does not create MeshPart assets, only the render mesh, you have nothing that you can archive, but as far as I can tell, this is not different from the AssetManager import?

Let me know if I misunderstood something here; it’s always difficult to make sense of Mesh vs MeshPart vs RenderMesh etc… Very likely I missed something :slight_smile:

The big issue is that, the asset is still on the Roblox platform, RenderMesh or not. When games get stolen from malicious acts such as exploits and or malicious developers, creators do not have the option to archive RenderMeshes. This plays a crucial role in securing assets and should behave the same as MeshParts.

We need the option to archive RenderMesh(es). As far as I know, archiving the asset prevents anyone else from accessing the asset on the platform overall, which is very ideal when needed to secure any leaked creations.

Edit: The meshes tab shows all meshes but any RenderMesh type. create.roblox.com does not recognize it in the create marketplace but still accessible through Roblox.com/library/AssetId


Sorry for the super late response, I got a new pc and it slipped my mind to log back into devforum.

Like Harley said, the main issue from being unable to archive a rendermesh is that archiving allows us to prevent the asset from being loaded into games after it’s been archived (which helps resolve the issue in the case that the mesh is stolen by malicious users and developers).

As for those who do have this issue, it seems that when you upload a mesh through asset manager instead, it does not upload as a rendermesh, thus allowing you to archive it. If you think you might need the ability to archive a mesh, you should upload your meshes via asset manager instead.

We definitely need the option to archive RenderMesh and plus add a ‘search’ features in uploaded meshes. It’s so hard to go through a thousand meshes one by one. They already pointed out everything so I guess there’s nothing else to say