Unable to remove CreatePlaceAsync() places within a game

A while back, I was experimenting with CreatePlaceAsync() before I ultimately found a better method for what I wished to do. At the time, the limitation of filtering-enabled places being unavailable to <13 was not introduced, and I had been unaware of filtering-enabled (or non-experimental mode now), and so the game was filtering disabled. As such, all the places created were filtering disabled, affecting the whole game’s view to players (the whole game appears to be in experimental mode, despite all the places except those aforementioned places (the createplaceasync() ones) being filtering enabled).
Therefore, I hoped that by removing the places from the game, it would remove this view. Unfortunately, this isn’t possible for some reason, so I tried to edit the places individually and set their filtering enabled to true, but when I publish the place, it errors with this:


This means that the only solution I can think of is to transfer the filtering-enabled places to another game. However, this will result in the wiping of all player data, which would be annoying to say the least, but possible. Before I do this, I wanted to know if there were any solutions anyone else knows of?

TL;DR - I need to either remove places created with CreatePlaceAsync(), or somehow flip their filtering-enabled state to true so that the overall game is accurately displayed as non-experimental mode.

1 Like

Can you not just create new places with the same names?

I had the same problem (which was causing bigger problems than just the filter) here:

I’m currently in the process of removing all 27+ million places that my game created with the API.

1 Like

I have that same Error when trying to do the samething! It also occurs when you want to save something in the place that was created using CreatePlaceAsync()

1 Like

I don’t need those places at all, they’re irrelevant to me now. I could reupload the main places under a different game, but that would mean losing all player data.

Im assuming you have all the placeID’s that were created with :CreatePlaceAsync in a datastore. Why not just make the template place FE = true and just change the Datastore Key.

Just leave the old places alone

That’s not the problem I’m having, unfortunately. My problem is that the old places affect the whole game’s experimental mode-ness(?) - so despite the main places being filtering-enabled, since those old ones from CreatePlaceAsync() are in experimental mode, my whole game appears in experimental mode. Since I can’t update the old games, or remove them, I don’t have a solution.

1 Like

Afaik Roblox cant do anything for you. I hope that thing sorcus was talking about at rdc 17 (Being able to get all datastore keys [most likely in a pages format]) becomes a reality. At that point it may become possible to export your keys and data in a format in which you will be able to mass set in a new game’s datastore environment. (Although even that would take a while considering current datastore throttling and a respectable player base)

1 Like