"Unable to Update Role" When trying to change role name or description

Hello Developer Forum,
Recently in my group CreamPuffs Bakery I have added new roles to the group. In doing this, I realized I could not edit any information in my first role. This occurs with: Name, Description, Rank and Permissions done in any combination. Here are the settings:

This bug has happened in my group only in this role. It is the role granted when the group is joined.
The bug started happening To my knowledge when I purchased new roles from the group and then tried to edit that role.

  • Steps to reproduce the issue (be minimal, specific, consistent!);
    To reproduce the bug I am not sure how to do this 100% of the time. I tried editing other roles and making them identical to this one but I could change them again.
    The rank number is 2
    All permissions are of except View group wall and shout.
    I would appreciate if anyone else has expereinced this what they did to cause it. :smile:

It looks like you can edit it just fine.


Ill screen record and send it then it must be an issue exclusive to me.

1 Like

I’ve seen this before, usually it is multiple people trying to configure the group at the same time. It’s something where all you need to do to fix it is to close out the webpage and retry, hope this helps!

This has been occuring for weeks and I am the only one out of everyone with permissions who is dealing with the new roles. I have checked the audit log and no one has changed anything in the past few wees other than me.

I see, did re-opening the page help? if not, try using a different browser than the one that you’re currently using.

This is what I get when updating: Screen record could not upload:

1 Like

I tried using my phone after closing the webpage on my laptop. Tried it on my phone but still no results.

1 Like

The issue is taht it was incorrectly moderating the role title when a space was added. I have given the error codes and all the information to @BitwiseAndrea she has been amazing and helped me solve the issue!


I am in the process of checking over bug reports and following up on some bugs that haven’t received any activity in a while.
Is this issue still occurring or can you confirm that this bug has been resolved?


got this issue today, was unable to promote a user. happened after updating a role and changing the name back didnt do anything

1 Like

I’m experiencing this right now. When I went to update one of my group members’ roles, it simply prompted me saying “Unable to update the user’s role.”. I have not changed anything in the group’s settings for a few of days, so it seems unlikely to me that updating a role is the cause.

hello @vundeq

Roblox Disabled the endpoint
More information here: Attention group owners: Critical group security flaw with ranking users - #4 by Hooksmith

That means, That all setrank functions of the group admin is now not working.

Also Please This is an old topic, I don’t think it’s a good thing to take it back for this problem
you’d better create a new topic or just watch this: Unable to Rank Someone in Group Bug

Just wait roblox to fix the problem.


Thanks for putting this here! Very helpful.

The original issue here is different (see solution I just marked).

For the most recent issue, please refer to this topic:

Closing this topic since it was resolved before it was bumped.