Unable to use wedges to angle blocks recently

So, in the past I used to be able to drag a block onto a wedge and the block would automatically rotate to match the angle of the wedge. Recently however, when I try to now it just does this.

I’m not sure what’s causing it. None of my settings have changed since the time I was able to drag it on. Rotating it manually is useless as I don’t have the exact measurement of any given wedge. The wedge I’m using is a WedgePart as shown in Properties>Data. I was told by someone this might just be the version of studio I’m using but I uninstalled and reinstalled studio and it’s still the same. I also asked a friend to see if he could do it in his studio and he could. Any idea on how to fix this?


It’s weird, I’ve never seen anything like this before.

But I assume you can just use trigonometry to calculate the orientation from the dimensions of the wedge.
And then you can use Pythagoras to find the position it needs to be.

Let’s say we want it the same orientation as the wedge’s hypotenuse so that it rests on that edge,
Orientation is a vector3 of Y,X,Z.
The X and Z do values do not change as you are only tilting it on the Y axis. (First number)

After this, it’s just simple trigonometry to find the angle that the incline is in. We can use any of the sin, cos, tan functions. But let’s use tan for simplicity so we don’t have to deal with the size of the hypotenuse.

Tanx = Opposite/ Adjacent

So to find x (Angle of inclination), you just do arctan(Size of Opposite/ Size of adjacent)

(For my case, size of my wedge is 28.5, 5, 7. This means that the height (opposite) is 5, and width (adjacent) is 7). So I would do arctan(5/7) which is 35.54 degrees.

This gives you x, which you plug into the first/ third value of the orientation through explorer. (You didn’t use ctrl L for axis as the Y axis appears to be going into your wedge rather than vertically up, so I can’t determine which is X and which is Z.)

Now, if you want to find the position, let’s say to put it at the direct middle of your wedge. It’s Pythagoras. An easy way to avoid too much complicated maths is to copy the position of the wedge, then put it into the position of the block so that they share a single midpoint. You don’t even have to calculate the distance from the middle of the wedge to its diagonal plane since roblox treats the wedges like cuboids, so the midpoint IS infact its diagonal plane.

My wedge has a position of (9.25, 2.5, -2), so I just copy and paste it into the position of the part.

All you have to do now is press ctrl + L and then use the Move tool to diagonally drag it out the length of half the side of the cuboid. And voila, you have your part on the edge of your wedge without fancy tools.

My wedge had a height of 1 stud, so I just pressed ctrl + L and then moved it up by 1/2 studs, so now I have my block on the surface of my wedge.

Now, you might also want to restart studios and see if it helps if you don’t really want to do the above maths. I suspect it’s a problem to do with constraints, or a glitch out of the hitboxes, that sometimes the studio code can’t calculate for whatever reason.

1 Like

There’s also the very rarely used transform tool, which literally allows you to select a surface to use as reference to move all parts on!

robloxapp-20201210-0420262.wmv (231.9 KB)


Thank you for replying! I had thought about using trigonometry but doing the math is just too tedious for me compared to what I used to be able to do. The transform tool seems like a great idea, although I tried it just now and for some reason I can’t select the surface of the wedge itself like you were able to, mine only selects the “box” around the part as a whole as seen below. This feature has been around for years from what I remember and I’m not really sure why it’d be removed if it’s not a glitch, If it is a problem on ROBLOX’s end I’m just hoping they fix it in an update!

You can’t select the diagonal face of the face of the wedge, since roblox considers wedges as cuboids. You’ll need to rotate the block first with trigonometry

(arctan Opposite/ Adjacent)

After rotating it, put the part on the same plane as the diagonal edge of the wedge. Click the Transform tool, and on the top left, click the plane selector, and then select the plane that the part is in.

1 Like

Calculating with trigonometry is overkill already. I remember that dragging parts on an angled surface automatically angled the part with it. The most odd part is how it is randomly rotating in the video. Could it be a bug?


According to the Announcement you should be able to right click and select Align Dragged Objects.


Just tried it in Studio, my version was still set to ‘Align Dragged Objects’, but turning it off went back to the way you were seeing it.
Turned it back on and it aligns to the wedge just fine.


Thanks for replying! I was rotating it by pressing T and R, and the solution has been posted below!

Oh good, thank you! I should’ve guessed to check the right click options LOL

Oh wow, I completely missed this post.

It would be great information eitherway, thanks for bringing it to light!