Weird Roact error in output. Cause unknown

Hello, all!

Starting a few days ago, every time I test my game (I always use server tests)
I have been getting this error in the clientside output:

CorePackages.Packages._Index.RoactCompat-a406e214-4230f473.RoactCompat.RoactTree:130: attempt to index nil with 'root’

I’m not sure what’s going on here, and to my knowledge I don’t use Roact, nor have anything to do with it.

Any solutions? Thanks!


I am not that expert but it can be because of the plugin you are using

im pretty sure it’s a roblox error.

roblox uses roact for the majority of the core UI features (menu, leaderboards, chat, etc), so if you see an error similar to that, you can always count on it being a roblox error.


Just checked, i don’t have Roact purchased!
Thanks for reaching out!

I was hoping that would be it.
Will it eventually go away? :slight_smile:
Probably a best case scenario.

yeah it should go away, if it happens more than once, make a post in #bug-reports:engine-bugs

1 Like

Great, thanks! I will make a post in bug reports. It’s happened multiple times.

getting the same error over here
Näyttökuva 2022-12-05 205154

1 Like

This is a bug on Roblox’s side, there’s already a bug report filed for it

1 Like

This has something to do with ReplicatedFirst:RemoveDefaultLoadingScreen(). Try calling this as quickly as possible instead of later.


We’ll look into this! Thanks for the response!
Edit: This fixed it! Awesome, thanks!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.