What happened to my studio?

Hey,
I was normally building in studio and suddenly the screen went black after importing a mesh.
Now It looks like that:

is there a way how I can save my progress? I tried to restart studio a few times. Someone please help.

(I’m sorry if I post this in the wrong category idk where to put this)

edit: I restarted my studio again and now it looks like this:

thanks for reading

2 Likes

Did you try to restart your PC and uninstall Studio and reinstall?

1 Like

yes I already did, nothing changed

1 Like

send me a screenshot of the properties of the camera in the workspace Please!

1 Like

Is this happening on all places? Perhaps try to create a new place and check it there.

1 Like

I had that issue, and I can’t remeber completely but I think I fixed it by going at settnings → rendering and set your rendering engine at DirectX11

Btw if that didn’t work, is your project saved as file?

1 Like

sadly didn’t work

It’s saved as a file I also tried to publish it, hoping that something changes

1 Like

i tried and it’s only at this place

1 Like

Go to File>Studio Settings>Rendering>Graphics Mode and set it to Automatic. Then restart Studio

1 Like

image

1 Like

I found a way to fix it!

Idk what exactly caused it but I fixed it with clicking on a random part/model (except the meshpart that caused that) and then on “Zoom to”

I don’t know why this happened but I’m glad it works now

3 Likes

It means you went really far into the void.

2 Likes

This is related to an issue where Studio will render debug stats onto the screen instead of the game.

What’s likely happened here is the camera has been moved to some place that cant simply be rendered

To the OP: Try starting Studio without plugins to see if that’s causing it. I’ve never seen this happen before in vanilla Studio.

If it is the cause of plugins, please DM your plugin list so I can better diagnose the issue.

The first image’s problem is caused due to the Graphics Mode setting being set to No Graphics, where it renders debug stats instead. The second image’s problem is caused by the camera being in the void, where something goes when you try to make it look at it own position with CFrame.lookAt.