Meshparts not importing correctly


#1

I’m trying to get rid of these lines that show through the model in order to create a very smooth looking model, but I am unaware of how to accomplish this.
This is an import from Blender, was wondering if anyone might have any tips on how to prevent this when importing as meshparts.

Thanks for your time.
-Shepherd.


#2

If you want the object to look more like the one on the right in the below image, do the following:

Steps to make an object smooth in Blender
  1. Select the area that you want to make smooth
    8245

  2. Go to Mesh.

  1. Go to Faces.

  1. Select Shade Smooth, you may have to scroll down to see this option.

Once you’ve selected that option, the area or object that you previously selected should now be smooth like the below image.

8250

To make objects like they were before, select Shade Flat.


If you have any questions about the above process let me know!

Alternatively: If this wasn’t the right answer to your question and you were referencing the gaps in your model this could mean that the normals are inverted on the object.

This is identifed in Blender by faces that look like this:


If your model looks like this in Blender (green are faces that are inverted):

8252

But the below in Roblox, this is the issue.

8253

Fixing inverted normals

Method 1: Recalculate outside.

  1. Select your object.

8254

  1. Go to Mesh. (Alternatively from this point you can press Ctrl+N and skip to #4.)

  1. Go to Normals and then select Recalculate Outside.

  2. Your model should look like this, if this was the issue.

If your model looks like this in Blender, great!
This likely means that it’ll be the same in Roblox once you export it.

8259

If it wasn’t then the issue you’re encountering let me know and I can explore some other options that are much less common.


If none of the solutions above worked for you or you need help understanding anything, let me know and I can explore some other issues that are much less common.


#3

As mentioned in the post above me, i believe the issue lies in the normals facing the opposite direction. Unfortunately the explanation you provided is hard to follow. If your answer is not resolved, please provide a more detailed description of the issue.


#4

Yeah, I was referencing the gaps in between the parts. Sorry about the confusion.
I’ll let y’all know if that’s the solution.
Thanks for the response.


#5

If you knew, there was an option in Blender to display where the normals are facing, and that easily could assist me on finding which faces are incorrectly flipped.


#6

Oh sure, you’d turn “Display face normals as lines” on.

To do this, select your model, go into Edit mode, open the Properties panel (N), scroll down until you see this.

Once you see it, your model’s normals should all be visualized better, change the size of the lines with the value to the right of the button.


If you have any questions about this, let me know :smile: