“Publish to Roblox as” does not let me overwrite a current place

  1. I have a current published place “testes” with nothing.
  2. I have a .rbxl file with something
  3. I want to overwrite the current .rbxl over “testes”
  4. Nothing is overwritten:

You may also notice that when I do “Publish As”, the confirmation window automatically closes, unlike when it works correctly.

Here are my today’s logs:
logs.zip (145.4 KB)


I noticed that a previous “Publish as” was effected. It seems that there is a delay or a temporary error:


I’ve encountered the same problem recently, you’ve just gotta do “Save to Roblox as” instead.

1 Like

I tested it here and “Save to Roblox as” had the exact same problem. :-1:t2:

Same here

I can’t publish game to testing stuff even make copy and publish copy file to place probably my file is large it likely 131MB


1 Like

Thanks for the report! We’ll follow up when we have an update for you.


It looks to me like this is being caused by a bug in the protection we have in place to prevent overwriting a place with an active Team Create session. We’ll try to get this fixed up as soon as possible.

For now, as a workaround, you can disable TC for the place you want to upload over, publish your place over it, then re-enable TC afterwards. If that doesn’t work let me know.


Hello, I have the same error but TC is not activated. Every time I try to publish/save large files it doesn’t work, the one I’m talking about is 60MB.

But for my friend, to whom I gave the file, he managed to publish it. The problem is that I can’t ask him to save/publish the game each times I update it.

Hope that you will find a way to help me!

You’re right.
By disabling Team Create in the project published BEFORE, it makes me able to publish the .rbxl overwriting this place.

Disabling Team Create is a bit tricky; did you do these steps on the previously published place before trying to publish the new project on this existing place?

Glad to hear it works. For some transparency here I’m filing two bugs about getting this fixed. These are:

  • We should not block uploads for a TC place unless there is a genuinely active Team Create Session
  • The error message should indicate that the failure is happening due to Team Create instead of being a generic 500 error

@ThePro4412 Could you send me a DM with the Studio logs from when you try to upload? I can look into it soon. At a guess it sounds like your trouble might be due to a shaky internet connection which there isn’t much we can do about, but I’d be happy to check the logs and look for anything else that might be trouble.

For the cleanest log, start up studio, open your rbxl, try to upload, then quit immediately. It is helpful to have as little extra stuff in the logs as possible.


After i disabled tc and publish again

my file is big i can publish when lower 120 mb but this 131mb
i hope this get fixed.

1 Like

Where do you see the maximum size you can upload?

Unfortunately the size limit is something we can’t lift at this time. Right now we guarantee that a 100mb files will work but can’t promise that anything more than that will upload. For somewhat complicated reasons it is possible to sometimes save places bigger than 100mb, but that depends on how well they can be compressed so there isn’t a hard size limit that I can give you.

For now your only option is to reduce the size of your place file by deleting things you don’t need so it can be uploaded, but I can’t say by exactly how much.

1 Like

The problem is still happening.
When will it be solved?


Sorry for the delay here. We recently shipped some changes to that save process that should make it so this problem no longer happens for places under 100MB, but that size limit still remains in place.

We’re actively working on ironing out any issues related to saving at this time, so if anyone has seen this error happen recently (the 500 internal server error) please let me know. Otherwise I’ll close out this thread shortly.