2 failed to load sound IDs that I can't find YET AGAIN

This post is kind of a continuation of the past post I made in March.

Whenever I, or anyone respawns in my game, these errors pop up.

failed to load sound bug

It’s getting annoying and whenever I or someone respawns, these errors cause a lag spike for a short time.

Again, I can’t find the IDs. I used ‘Ctrl+Shift+F’ and nothing pops up.

Also adding that 4 errors (the same rbxassetid://0s) are sent in the console once I join a game, but fixing the main source of the bug will probably get rid of these.

If anyone knows how to fix this, please help me out!

Is there any sound in your game that makes you use the .SoundId

I have a lot of scripts that use the SoundId code.

may you show us the scripts that use the soundid?
perhaps they error and output as 0?

are there any sounds in startercharacter or starter gui?

There are none in StarterGui, but there are scripts in StarterCharacter that have sounds.
I have tried deleting the scripts and checking it on studio if it made a change, but the errors still pop up.

can you show everything that is for sound in scripts and explorer?
perhaps its starterpack maybe? (if you have a tool)
also where does the error come from? client or server?
also does this only happen in studio?

thats not something a sound would do.
have you checked for any backdoors too? (just in case search for require( in every script by pressing ctrl + shift + f at the same time)

I think because of the 22nd March Audio Update, the Audios that are more then 6 seconds cannot be founded, meaning all of the audios that are more then 6 seconds is “invisible”; cannot be played.

Unless if you do over 30 audios at the same time (Less then 6 seconds (Of course) the audio will work because you did 30 audios (Read the 1st Parenthesis, of it) JUST, to make 1 single audio.

You can call them Parts to the music.

I actually did check for require(, but I didn’t find any scripts that would be a backdoor. Later I’ll go check a second time just in case.

yes but the errors didnt have any type of “ID” it was just 0 as shown so it means its not because of the audio privacy update
a real audio from this would had a id inside it and not a “0”

Checked audios through Audio Discovery, and there are no sounds that are longer than 6 seconds. Even checked sounds in the StarterCharacter scripts, they’re not longer than 6 seconds.

If I showed everything that includes sound, I’d have to go through a lot.
The tools have nothing wrong with them, as far as I know.
Don’t know where the error comes from.
It happens in studio and ingame.

maybe check what the sound id of each one was?
tools always are carried in the backpack and reset only on client so you should check them too

i think you can do this a easy way of just searching with a script in command bar or console after you spawn to see where they are.

for i,v in pairs(game:GetDescendants()) do
	if v:IsA("Sound") then
if v.SoundId == "rbxassetid://0" then
print(v:GetFullName())
end
end
end
1 Like

It worked! The sound was inside a tool. I tried the getdescendants solution before, but I did it in studio build mode instead of ingame. Whoops, mistake on my part.

Thanks for the help! Now I know what to do if a problem like this happens… again.

No problem Im so glad to help you out in this situation? but i still have a question
how does a sound error lag spike players?

Maybe it’s trying to load the sound, but since there’s no id, it has trouble loading it.
idk, i don’t have enough experience to identify why it happened lol

1 Like