A regular rolling sphere does not appear to slow down

I am using velocity briefly to propel a sphere across a flat surface, but it barely slows down. How can I change the sphere so that it slows down quicker?

1 Like

Set CustomPhysicalProperties. Higher Density and Friction should help.

It doesn’t with PGS.

1 Like

This does not seem to make a difference, did it for you?

Yes, it did.

You can try setting the number to a lower number like .5 if it’s not slowing down as fast as you like.