Accessories not moving with custom character

Hello! I have been working on a custom cat that can take your avatar’s outfit and put it onto the cat. But, my issue is that the accessories that I have put onto the cat from my own avatar doesn’t move with my cat’s animations. The items seem to be attached to the cat, but just not moving. Im not a big scipter, but I will take scripting suggestions too!

Characteristics Of The Cat

  • 20 mesh parts
    • Same as R15 with the exception of the tail (1), ears (2), and eyes (2) parts.
  • 44 bones

Examples & Pictures

I tried to do a little head bobbing animation as well, just to see if it was my animations.

Properties of the model and workspace

Thanks for reading and helping me out!

1 Like

Use WeldConstriants

Lorem ipsum dolor sit

I tried that, but Welds and WeldConstriants aren’t working for me


Hey, I’m not sure whether you’ve found a solution, but I recently found out that Roblox has had a similar feature for a few years by now:

Bon Appétit.

I believe all items/accessories need to be added to your armature and weight painted and parented to the bone you’d want it to move with within whatever 3D program you’re using.

That’s what I ended up doing, but we have to import each and every item we want and weight pain it. It’s not as efficient as just scripting a roblox item to load in and weld it, but it works. Thank you anyways though.

1 Like

I will have to look into these. Thank you for directing me to these posts!