Accessories with a SpecialMesh without a Texture show studs

Reproduction Steps
Put an accessory with a handle that has a SpecialMesh that doesn’t have a Texture onto a Humanoid.

This repro file gives your character a hat without a texture. You’ll most likely have to upload it as an actual game as the bug doesn’t seem to appear in Studio.

HatStudsRepro.rbxl (27.3 KB)

Expected Behavior
The hat shouldn’t have a texture or any studs.

Actual Behavior

The hat will have a studs texture put onto it. This doesn’t seem to happen in Studio, only in-game.

Workaround
The current workaround is changing the texture to something that won’t load, like an invalid URL or a random keyword. However, this will make the hat appear gray.

Issue Area: Engine
Issue Type: Display
Impact: Moderate
Frequency: Often
Date First Experienced: 2021-09-27 00:09:00 (-04:00)

27 Likes

Hello LSPLASH,

Thank you so much for reporting this AND for taking the time to make a test case, this really helps us track down the issue!

We have a fix for this which should release shortly.

This bug is due to us working on some new technology on how characters are drawn. Which in the future will help us increase performance and fidelity. We did some testing with enabling this feature in client. This is why you didn’t see it in studio, since we didn’t enable this new feature in studio for the public yet.

Depending on the level of intrusiveness this is causing we may temporarily disable this new feature on client as well… I will discuss this with the team and I will update this thread later.

Thank you again for reporting this!

10 Likes

Hello again LSPLASH,

We’ve discussed this internally and come up with a decision.

We would like to keep the new technology on in the general case, because the way we do new version releases would mean we would have to disable the new feature till next Wednesday/Thursday. We would like to leave it on so that other people can report any other issues which we can then fix. Whereas if we were to turn the feature off then we would need to turn it back on next week and then see if there are new issues. This will slow down the entire process. (That said if this issue gets reported a lot, then we will turn it off globally, but special meshes are sort of deprecated, so we don’t expect high usage)

That said, we understand that this is inconvenient for you and you might not want to do work arounds for this. So we can disable the new feature for your particular experiences until the next release which contains the bug fix if you prefer. If you do prefer this please let us know the place ids.

If you do work around this and getting the basic flat color by assigning a texture, please use a low resolution texture (think 4x4 pixels or something like that) to keep memory consumption low. Obviously if you wanted to assign a normal texture, chose whatever resolution that gives you the fidelity you want.

Please let us know what option you prefer.

7 Likes

This new update has caused issues with Player and NPC appearances, for now I’ve switched to using VertexColor and a white texture as a work-around, but I would prefer to not have to do this.
NPC:
RobloxPlayerBeta_NbXGJ1mIMv
Player:

If this update could be disabled until the issue is fixed in my place (7106880218) that would be amazing, thanks.

1 Like

Thanks for the reply. If you could disable it for my place(s), that would be great. Here are the IDs, all under the same universe/experience:

1466995005
5565801610
5911121311
5945728589

After about an hour after posting this, about half the players are now reporting that they crash after trying to teleport to a gamemode/different place. Is this related, or were my places not updated yet (making this a completely separate issue)?

Hello,

We are aware of the crashes, we’ve turned it back on which will give you the studs problem, but should prevent crashes.

Please rest assured that we are doing all we can to get this resolved as quickly as possible. And apologies for the problems this is causing for you.

7 Likes

The bug seemed to be gone for a few days, but just now I got a few reports that some players are having the studs issue again. Any news on when this should be completely fixed?

1 Like

Do you happen to have a time associated with the reports? There were some features temporarily enabled, which may be related. This would help to track down what causes the issue.

It will also be helpful to know if the players teleported or not (due to some internal details, this actually matters)

The reports for the studs bug started at around 6:30 PM EST yesterday. I didn’t get any reports for the teleportation issue

I did some looking around the code and you are totally right. I re-enabled the feature, but forgot to enable a fast flag for the fix for this. So sorry about this!

2 Likes

So… yet again, the issue was solved for a couple of days, until today. First report I got was around 6:40 PM EST. After checking, I seem to have the issue as well. Hope you can get it fixed soon.

1 Like

Yeah I am looking into it right now. FWIW this was tested in isolation (with the test case you provided) as part of the test suite we added. When we flip the flag, we first look for crashes, then for non crash issues.

2 Likes

Should working again on the places you reported:

1466995005
5565801610
5911121311
5945728589

I will test again on these universes and try to figure out why I don’t see it break on a development build, but do see the break on a production build.

2 Likes

FWIW we have fixed it (the main reason it broke you before was that viewport frames were broken). I have verified this in 🎃 RAGDOLL UNIVERSE 🎃 - Roblox.

Unfortunately I missed code cutoff, so we will have to wait till release 501 for this to be in. But please rest assured that until that point we will filter out your place for the new tech, so you should not be impacted for 499 and 500 (and 501 with the fix)

Again apologies for the inconvenience! I understand how frustrating it is that the game breaks due to things outside of your control. We are doing our best to not break experiences, but the features are quite complex and incidents happen.

4 Likes