Accessories wont position correctly onto NPC

Hello, I was trying to make a rig to be used as a NPC and also as to be rendered for a games thumbnail.

When I was trying to do that, the accessories such as the hair and hats are not in the right position. I was only just putting the stuff I put in with this command (“game:GetService(‘InsertService’):LoadAsset(assetidhere):GetChildren()[1].Parent = Workspace”), and then ungrouping it, after that I just put the MeshPartAccessory into the Rig’s model.

I can say it is R6, I did try it with R15 but did not work. I could just put it forcefully onto it but I kind of am one of those people that want it to be perfect. How can I correctly position and also look normal in the game. I think this is a common issue but I am stupid enough that I can’t find it. Thanks.

2 Likes

Maybe this will help?

The problem is that it is using a plugin to load players instead of making a custom one. I will try this later.

When you tried the R15 rig are the Attachments for the Hair/Hat in the right Position?

Ya, that’s why I wasn’t sure if it would help or not. I hope you find something better.

If this is the case, you could try these solutions:

  • Creating the custom character in a different place/experience

  • Manually correcting the position of the accessory

  • Restarting Roblox Studio and deleting the accessory and pasting it again to the character

Gonna reply to all of the bulleted list suggestions

  • Tried it, sometimes work, sometimes does not
  • As I said before, I want it to be almost perfect and even when testing it does not snap back
  • Also did this, same issue.

Well if those don’t work…

You could try this solution I found earlier.

I should mention that there is a HatAttachment, I don’t really make custom hats or anything so I might be stupid about it but its still positioned correctly its just not snapped correctly and when I test it does not do that as well. I just came back into the platform after being away from roblox for a few months and forgot how to make rigs because I used to be able to do that by dragging the assets into the Rig’s model. For some reason, it only affects on some models and some are not affected.

Are the accessories welded to the character when you insert the NPC?
if so then you could either reset the accessory welds of each accessory and see if the hats go back to their original position, or you could playtest the game with the character in it and see if the hats go back to their position after doing that, and if they do then just copy the NPC and paste it back into studio.

If not, could you give a little more detail on how the NPC is built, please?

All I know is that I am using UGC items, and using the default R6 rig from rig builder prebuilt into studio. I think it must be something with UGC

Also, testing does sometimes attach but not always, its mostly in studio thing I guess.