AcquireFrameBuffer causing consistent frame drops

I’ve been experiencing Studio running really poorly since the end of last week. Have all plugins disabled and have tried re-installing Roblox. Looking at the microprofiler it seems like something called acquireFrameBuffer is causing issues. This is seriously affecting my ability to develop anything smoothly, for the time being I have to go as far as changing what operating system I’m working on to get anything done. Attached is my profile dump from an empty baseplate.

microprofile-20200316-143727.html (1.8 MB)

Running Studio version 0.423.0.391560 on macOS 10.15.3.


Try disabling VSync.


How do I turn off vSync? Tried turning off “Frame Rate Manager” but nothing changes.


This issue is still happening and so far nothing I have done has been able to fix it. Have tried restarting multiple times, disabling all plugins, reinstalling studio, everything. My operating system is up to date and so is Roblox Studio.

My system specs in case needed:
Screen Shot 2020-03-19 at 12.43.04 PM

  • Try disable all of your startup programs such as Chat Clients / Game Updaters / Screenshot Managers. There might be some program which is drawing an overlay (with nothing in it) / recording the framebuffer in a way that plays badly with Roblox’s performance.

  • If you haven’t already, try updating your graphics drivers. Unlikely to be the culprit but it’s worth a shot.

Thanks for the reply, however none of those were the issue. Ended up doing another deep deletion of Roblox, and a reinstallation did the trick. Not sure how the issue surfaced in the first place but this seems to have worked for now.