ActiveCameraController did not select a module

I got this error when making something with camera, I found nothing about this error, and I don’t know how to fix it, and if there is anybody that would need fix for this, then this would be the first solution for that.

    workspace.CurrentCamera.CameraSubject = game.Players.LocalPlayer.Character.Head
workspace.CurrentCamera.CameraType = Enum.CameraType.Custom

I had the same error and was very confused.
The warning comes from the playerscript camera script.

if not newCameraCreator then		
	if cameraMovementMode == Enum.ComputerCameraMovementMode.Classic or
		cameraMovementMode == Enum.ComputerCameraMovementMode.Follow or
		cameraMovementMode == Enum.ComputerCameraMovementMode.Default then
		newCameraCreator = ClassicCamera
	elseif cameraMovementMode == Enum.ComputerCameraMovementMode.Orbital then
		newCameraCreator = OrbitalCamera
		warn("ActivateCameraController did not select a module.")

I had this error and I am not sure what I did to fix it. I was able to make it come back up again with a wait() in my RenderStepped event, but that only worked once. Its potentially related to how the player and scripts load in.

If I had to guess, its because 2 scripts are trying to set the cameraMovementMode or calling the ActivateCameraController at the same time, and it is overloading the function, or something else.

Perhaps someone who has better knowledge of roblox core scripts could explain.

If I would recommend something, it would be to check if other scripts are trying to change the camera at the same time, and adding some :WaitForChild’s

reply because no other references to this error


Just happened to me, in game.
Wonder what’s causing it.

Rejoining didn’t fix it, either.


Im not sure why this is doing the but it seem to fix its self if you set the CameraType then Set its Subject. I have done testing with this any every time I did not set the Type Before setting a new Subject it always gave me the error then after I set the Type then the Subject I have not got the error yet so.

Camera.CameraType = Enum.CameraType.Custom
Camera.CameraSubject = Subject

The error still occurs when CameraType is set to Scriptable, although I don’t believe this error breaks anything.

1 Like

I added a


And it stopped the error.