I just had a chat with Conor. We’re submitting that the new name be
GetPlayerUsernameFromPlayerUserIdAsyncYielding(userId)
Already have a thumbs up from our supervisor
[quote] I just had a chat with Conor. We’re submitting that the new name be
GetPlayerUsernameFromPlayerUserIdAsyncYielding(userId)
Already have a thumbs up from our supervisor [/quote]
UserId = User Identifier (or could be that all places with Player and User were replaced with Account to add even more to it)
Adding to the “Previous”, this would be one hell of a method.
It’s only called Async because internally it’s asynchronous, yet the behaviour on our side (where the API is exposed and should reflect) is synchronous and therefore shouldn’t have the Async prefix. :X
You’d think because it’s the lua-side of the API, it would better reflect the Lua side. Telling us it’s asynchronous on the C-side isn’t any help (why do we need to know that?), and is just confusing with the synchronous behaviour on the lua side.
[quote] It’s only called Async because internally it’s asynchronous, yet the behaviour on our side (where the API is exposed and should reflect) is synchronous and therefore shouldn’t have the Async prefix. :X
You’d think because it’s the lua-side of the API, it would better reflect the Lua side. Telling us it’s asynchronous on the C-side isn’t any help (why do we need to know that?), and is just confusing with the synchronous behaviour on the lua side. [/quote]
I completely agree, I think methods that actually DO yield on the lua side should be suffixed with “Async”. It’d be nice to note that these methods are async on the c-side in the wiki’s description of that method though.
WaitForChildAsync? No thank you If you’re going to use something from any API and any programming language, you’re going to know what it does. You can’t get someone’s userId from their name without knowing that GetUsernameFromId exists, and if you know it exists you know what it does. Async is just a redundant reminder that isn’t needed.
How about GetCurrentPlayerUsernameFromPlayerUserIdAsynchronousCPlusPlusSideButNotLuaSideOnTheLuaSideItYieldsItIsNotAsynchronousOnTheLuaSide(int userId)?
More like…
GetCurrentPlayerUsernameFromPlayerUserIdAsynchronousCPlusPlusSideButNotLuaSideOnTheLuaSideItYieldsItIsNotAsynchronousOnTheLuaSideButReallyIsSyncBecauseItIsAYeildFunctionAndAllItDoesIsMakesTheFunctionNameALotLongerThanItShouldBeAndSuperHardToRememberWhatIsAnAsyncAndWhatDoesNotHaveThatFormOfEndingAndIRealizedThatThisFunctionIsSuperLongAndGoodJobRememberingAllThisLikeRememberingAllTheAsyncsAndNot(int userId)
In terms of RDC East, no one brought it up. I wish I did when I mentioned things like AngularVelocity.angularVelocity being camelCase rather than AllCaps.
For the forums, I have never seen it anywhere.
That question was more directed at Dave/Gamer101 since they’re both interns with direct access to the ears of the ROBLOX staff + it’s the brainchild of TheGamer101.
Knowing if something is async is especially important when using metamethods that don’t permit yielding. Also having “FromUserId” makes it so we could potentially have a different function like “FromOwnedUserName.” It may seem weird but these descriptive names are more future-proof. -and overloading can get weird.
I’m asking them to change the name for preference – not because my game needs the change. Adding x = y, z = w, etc at the top of every script is wasteful. Why should I have to clutter my code and do all of these roundabout workarounds just because ROBLOX didn’t name their methods what they should have? They should be named properly, and as this thread has proven, there are a lot of other like-minded people.