AdjustSpeed(1) is not working correctly

Hello everyone!
I am working on a cuff system and I have some issues with the Animation for it. I am pausing the Animation with AdjustSpeed(0) and later I want it to go on with AdjustSpeed(1) but that is not working. I searched a bit around and I think that the issue is that Anim:AdjustSpeed(1) must be contained in the if statement and not later in the else statement and like that it is working but that is not what I want and need. Anyone has a idea on how to fix that? The script is contained in a tool and binded to a RemoteEvent

local rep = game:GetService("ReplicatedStorage"):WaitForChild("ArrestEvent")

local UnloadedAnim = script.Parent.Animation

rep.OnServerEvent:Connect(function(plr, target, cuffed)
	local hum = target:FindFirstChild("Humanoid")
	local Anim = hum:LoadAnimation(UnloadedAnim)
	if cuffed == false then
        --AdjustSpeed(1) would work here after like wait(1) but thats not what I need
		Anim:AdjustSpeed(1) --That does not work


Have you tried print debugging? Try printing in the different clauses of the if statement.

I did and it worked so it is a problem of the AdjustSpeed() Event