AI Pathfinding cannot find a correct path

My AI can’t path through gaps that should be wide enough(2 studs) and gets stuck. Even when I set the Agent Width to zero the path returns NoPath. Is there something I’m missing? If I move it to a baseplate for testing it works, even with the room and its cabinets.

The bottom neon part is the start, and the top neon part is the end.

Oddly, if I playtest and delete the cabinets when it’s at the start, it fixes itself. There’s no way that the cabinet would block it, especially since I made their collision group not collide with the AI collision group.
I’ve checked the workspace, no parts 100,000 studs in the distance messing up the nav mesh. Any idea what could be the problem?


Pathfinding can be really wonky sometimes, but if you found out that removing the cabinets fixes it, you could try adding a PathfindingModifier so the pathfinding can pass through the cabinets

This worked, but it really should not have. Roblox really needs to update pathfinding, it’s ridiculous. Whats the point of introducing new parameters like CollisionGroups if they don’t work?

1 Like

Nevermind, it still doesn’t work. I have AI that’s following a set path, and AI that roams around. I can’t make some objects passthrough for the path followers because it’ll mess with the roaming AI.

You can see that it’s not going straight through the VERY OPEN GAP. AgentRadius is 2.5, AgentHeight is 5.

If I lower the AgentRadius, they can follow the path barely. However, they often get stuck on things. Not only does this slow down them following the path, but also causes their vision cone to rotate, meaning they can spot a player accidentally.

Can’t you just use two separate pathfindingMofidiers? one for roaming and one for the set path

Even so, roaming still gets stuck on objects and can’t path through very wide corners. I can’t really bandage fix this, it needs a proper solution.