Aim animation does not work, why?

I’m trying to make a ads, aka aim down sight, and it has not work for some reason.

I also have scripts that makes it so you arms go up if your mouse goes up your screen, and one where you can see your arms in first person.

I’m also using the FE gun kit custom grip, made by @PrikaMeric34

So the problem is, when i aim down, the gun itself does not move.

Example:Robloxapp-20211024-1540099 GIF | Gfycat

Ive tried changing part0 of the motor6d connecting to the torso, to the right arm, (I’m also using r6)

Is there anything i can do, or something you can help me with?

:wink: :

Do any errors appear in the console when attempting to play the animation? Some of your script for context would be appreciated.

no, there were no errors, but thanks!

I think it might be something related to the gun not being properly Motor6’d to your arms/torso.

Or, it could be because the animation plays before the motor6d is put on.

The ads is an animation, but anyways i think it is motor6d’d properly, lookimage

Hm, try adding a wait(0.1) to the idle animation playing after the rigging is done. That might work.

I’m very confident it’s not an animation problem, as your arms moved freely to the ADS position.

I’m not good at scripting to i just added a wait(0.1) before the aim animation image

and this is what happened


Uh… that’s not what I meant…

If you could, maybe you could go inside of the kit you’re using and find the idle animation playing section. Other than that, I can’t help because I don’t know how to work with that gun kit’s code

Have you tested it without the player looking up and down? Seems like that’s what is causing the problem

Ok so, let me tell you about the gun system, in the gun tool, there are scripts about raycast and all the important things, so anyways the important thing is that there’s a mainmodule script in the tool, image
called Settings.

This is what it looks like


Yes, but what I’m telling you to do is to go inside of the actual scripts that handle the stuff (probably the GunScript_Local)

Try and find something related to idleAnimation:Play() or something along the lines of that

I tried searching for it (by pressing ctrl+h) but i could not find anything, but i dd find everything else, for example like auto, if its enabled it be full auto

I found the aimidle animation thing and put wait(0.1) and now the anti cheat kicks me out

Oh… that’s a shame…
I really don’t know how that kit works (I don’t know how the code works / operates), so I’m afraid I can’t help you much anymore

:frowning: thanks for helping thought. I might ask the person who made the gun kit

On the Motor6D, try making Part0 the HumanoidRootPart (where the rig is stored). This is how it is done by the avatar importer.

Another thing you might try is no Motor6D at all. Just a WeldConstraint. If all you want is the gun to follow the arm, it doesn’t need to move on its own.

I think I know how to make the aim animation work.

First, if your using the classic Roblox Animator Plugin there should be a animation priority that is found in the three dots. The animation priority are:

Aim Idle = Movement
Aim Fire/shoot = Action

If you want to make the aim idle and fire animation aim properly you could use this plugin.

But if you want a tutorial, here it is: